Personal tools
You are here: Home Forum Use Re: Problem with extruding mesh along path

Re: Problem with extruding mesh along path

Up to Use

Re: Problem with extruding mesh along path

Posted by Morten Ketelsen at December 16. 2012

All,

I am trying to model a spring with some coils. I did succesfully mesh the circular face of one end of the geometry. I also

meshed one wire along the length of the wire length. When I extruded the mesh along the path, I see a twist in the elements (please see attached pictures. I did check on the orientation of the edges. One edge is reversed. I suspect, this is the reason this issue. How can I fix the orientation of the edge ? Is there another way of fixing this ?

best Regards,

Morten

Attachments

Re: Problem with extruding mesh along path

Posted by Gérald NICOLAS at December 17. 2012

Morten,

I don't know whether your extrusion was done in the SMESH module or in the GEOM module. Nevertheless, I met a similar problem last week. I used the GEOM module:I defined a profile and then I wanted to extrude it along a path to create the geometry of a channel. See the attached file. Sometimes it works, sometimes it doesn't. It's hard to understand the reason. I wrote a message into the EDF internal bugtracker.

Regards.

Gérald NICOLAS

Attachments

Re: Problem with extruding mesh along path

Posted by Morten Ketelsen at December 22. 2012

Hello Gerald,

 

thanks for your comments. I did the extrusion in the SMESH module.  In the mean time, I can confirm, that manually

recreating the wire segment with a correct orientation fixes the problem. Though, it would be much more convenient to

be able to fix the edge orientation in the GEOMS module.


Regards,

 

Morten

Powered by Ploneboard
Document Actions