Personal tools
You are here: Home Forum Use NETGEN_3D Error

NETGEN_3D Error

Up to Use

NETGEN_3D Error

Posted by Kirill St at February 18. 2013

I have a problem to mesh my solid part with 3D automatic tetrahedralization.

I made solid part in salome (from step file imported from SolidWorks).

What could be the reason?

Thanks

Attachments

Re: NETGEN_3D Error

Posted by Saint Michael at February 18. 2013

Hi Kirill

A reason of netgen failure at 3D meshing is often a poor quality of 2D mesh, which in its turn caused by difficult geometry, e.g. by presence of narrow faces.

It is often possible to detect a reason of failure by analyzing the 3D mesh that was created anyway.

St.Michael

Re: NETGEN_3D Error

Posted by Kirill St at February 18. 2013

Hi Saint Michael.

 

Yes I realize what is the reason of the failure but I didn't understood what is the way to fix the problem.

 

Is it manipulation with the 2D mesh?

 

Thanks Saint!

Re: NETGEN_3D Error

Posted by Saint Michael at February 18. 2013

It depends on a kind of problem. Some issues can be fixed by adjustment of local meshing parameters, others can be fixed by modification of 2D mesh before 3D meshing.

St.Michael

Re: NETGEN_3D Error

Posted by Kirill St at February 18. 2013

I repair it by using the "Shape Processing" tool... Is it good idea?

The manipulations with 2D and 3D mesh didn't help me...

Re: NETGEN_3D Error

Posted by Saint Michael at February 18. 2013

Your idea is wonderful!

St.Michael

Powered by Ploneboard
Document Actions