Personal tools
You are here: Home Forum How to use Salome? Cannot active salome theme

Cannot active salome theme

Up to How to use Salome?

Cannot active salome theme

Posted by yongjin liu at November 02. 2009

Hi there,

I'm using salome 5.1.2 and I'd like to use Qt theme for the GUI by uncheck 'Use Salome Style' under view->theme menu. But I cannot make this done because the window is too large and I cannot active the 'Apply' or 'Ok' button.

What can I do for this? Is there any file I can modify manually? Checked ~/.SalomeApprc.5.1.2 but nothing related inside.

Attachments

Re: Cannot active salome theme

Posted by Vadim SANDLER at November 02. 2009

Hello,

 

You can add the following data to your .SalomeApprc.5.1.2 file:

 

<section name="style">

  <parameter name="use_salome_style" value="false"/>

</section>

 

Regards,

Vadim.

Re: Cannot active salome theme

Posted by yongjin liu at November 03. 2009

Vadim,

Thanks for your help, it's done but still need some help here.

The reason I want this is because the font in my solome is difficult to read and I thought maybe I can solve the problem by disable salome theme to make qtconfig active for salome too, just like other qt-based programs. But I'm wrong, now the font family is right but the font still looks strange compared to other qt-based programs. (Please refer to the attachment)

There's a post on salome font topic here:

http://caelinux.com/CMS/index.php?option=com_joomlaboard&Itemid=52&func=view&id=2220&catid=7

But unfortunately I use salome alone, not salome-meca and I have no libconfig library in my salome installation.

It's not a big problem but I'll appreciate if some one can give me a tip here.

 

Thanks and regards

Attachments

Re: Cannot active salome theme

Posted by Vadim SANDLER at November 03. 2009

Hello,

Actually, as I can see from the attached picture, SALOME theme is still used. Can you please modify .SalomeApprc.5.1.2 file as I have shown in my previous comment, then launch SALOME and attach resulting picture?

Regards,
Vadim.

Re: Cannot active salome theme

Posted by yongjin liu at November 06. 2009

Hi Vadim,

OK, I followed your previous comment and the attachment is what I got. Pleas take a look.

Attachments
Powered by Ploneboard
Document Actions