Personal tools
You are here: Home Forum Other... (new forum, problems, etc.) Error on Explode

Error on Explode

Up to Other... (new forum, problems, etc.)

Error on Explode

Posted by Alexandre Pecanha at February 20. 2018

Hi,

 

May I ask about an error in SALOME-8.4.0 universal binaries?

 

When trying to explode a solid the following error is launched: "GUI library corresponding to the user action can not be found or loaded"

 

If I remember well, something similar happened in 7.3 version.

 

Is that a release error or I've done something wrong during install procedure?

 

 

Best Regards,

 

Alex

Re: Error on Explode

Posted by ziad at February 25. 2018

I got the same problem with both 8.3.0 and 8.4.0 on Debian 9. Not sure if it's related but here is the message I get for both versions from the command line:

 

$ ./appli_V8_4_0/salome 

runSalome running on k55

Error when trying to access active network connections.

Traceback (most recent call last):

  File "/home/ziad/salome/appli_V8_4_0/bin/salome/PortManager.py", line 111, in __isNetworkConnectionActiveOnPort

    p = Popen(cmd, stdout=PIPE, stderr=STDOUT)

  File "/home/ziad/salome/Salome-V8_4_0-univ/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 710, in __init__

    errread, errwrite)

  File "/home/ziad/salome/Salome-V8_4_0-univ/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 1335, in _execute_child

    raise child_exception

OSError: [Errno 2] No such file or directory

Searching for a free port for naming service: 2817 - OK

Searching Naming Service + found in 0.1 seconds

Searching /Kernel/Session in Naming Service ++Warning: this type (Study,objref) already exists, it will be ignored.

Warning: this type (pyobj,objref) already exists, it will be ignored.

Warning: this type (SALOME_MED/MEDCouplingFieldDoubleCorbaInterface,objref) already exists, it will be ignored.

 found in 1.0 seconds

Start SALOME, elapsed time :   1.1 seconds

****************************************************************

     Warning: module HEXABLOCKPLUGIN is improperly configured!

     Module HEXABLOCKPLUGIN will not be available in GUI mode!

****************************************************************

****************************************************************

     Warning: module HYBRIDPLUGIN is improperly configured!

     Module HYBRIDPLUGIN will not be available in GUI mode!

****************************************************************

****************************************************************

     Warning: module BLSURFPLUGIN is improperly configured!

     Module BLSURFPLUGIN will not be available in GUI mode!

****************************************************************

****************************************************************

     Warning: module HexoticPLUGIN is improperly configured!

     Module HexoticPLUGIN will not be available in GUI mode!

****************************************************************

****************************************************************

     Warning: module GMSHPLUGIN is improperly configured!

     Module GMSHPLUGIN will not be available in GUI mode!

****************************************************************

****************************************************************

     Warning: module NETGENPLUGIN is improperly configured!

     Module NETGENPLUGIN will not be available in GUI mode!

****************************************************************

****************************************************************

     Warning: module GHS3DPLUGIN is improperly configured!

     Module GHS3DPLUGIN will not be available in GUI mode!

****************************************************************

 

This is a bug that was supposed to be fixed a while ago but it seems it wasn't.

 

Re: Error on Explode

Posted by Sita Drost at July 05. 2018

Me too, with Salome 8.4.0 (universal) on Ubuntu 18.04. I get those same error messages and warnings. Already posted my problem in a different thread on the same subject, but thought it would be no harm to reply to this one too. Any ideas, anyone?

Thanks!

Sita

Re: Error on Explode

Posted by Othman Ahmed at Saturday 01:10

I got the same problem when trying to use explode on ubuntu 18.04.

The problem exists for both 8.4 and 8.3  universal linux binaries.

I couldn't manage salome package for ubuntu 16.04 to work on ubuntu 18.04.

Best Regards,

Othman

 

Re: Error on Explode

Posted by Mario Storti at Saturday 03:24

Previously Alexandre Pecanha wrote:

Hi,

 

May I ask about an error in SALOME-8.4.0 universal binaries?

 

When trying to explode a solid the following error is launched: "GUI library corresponding to the user action can not be found or loaded"

If I remember well, something similar happened in 7.3 version. 

Is that a release error or I've done something wrong during install procedure?

 

Best Regards,

Alex

Hi Alex, take a look at the solution in this post https://www.salome-platform.org/forum/forum_10/564414485. It seemas that it is related to a version problem with the libjasper library. 
 
HTH, Mario

 

Quick reply
URLs will be automatically hyperlinked. Basic HTML tags are OK.
Powered by Ploneboard
History
Activate by Alexandre Pecanha on Feb 20, 2018 04:19 PM
Document Actions