Personal tools
You are here: Home Forum Other... (new forum, problems, etc.) URGENT! mesh module problem

URGENT! mesh module problem

Up to Other... (new forum, problems, etc.)

URGENT! mesh module problem

Posted by vaina at January 12. 2011

Hi everybody. I hope you can help me, I really need a working Salome platform as soon as possible.

A few weeks ago, I installed Salome 5.1.5 on a new laptop, I already use previous releases on other computers. Today I started a new project but I found out mesh module is not working. It opens but no 'nodes' appear in the object browser (sidebar), so I can't mesh anything. I tried to open old projects, containing meshed elements, and somewhat appear in the object browser (i think it's a little slow anyway). How can I fix the problem? Does anyone have my same troubles?

Thank you for your attention.

Re: URGENT! mesh module problem

Posted by vaina at January 13. 2011

please, is there anybody who can help me? have I to re-install everything or even a previous release? :(

Re: URGENT! mesh module problem

Posted by Christophe Bourcier at January 13. 2011

Well, I haven't met a such problem before. Could you explain more the problem? And post snapshots to better understand.

In the embedded python terminal, type: import SMESH_box

Does something appear in the object browser?

Christophe

Re: URGENT! mesh module problem

Posted by vaina at January 13. 2011

I attach a snapshot (I just created a cube in geometry module and opened mesh module to mesh it). I also typed import SMESH_box and obtained:

 

p, li { white-space: pre-wrap; }

>>> import SMESH_box

INFO - The directory /home/maurizio/salome_5.1.5/GEOM_5.1.5/lib/python2.4/site-packages/salome/salome is appended to sys.path

INFO - The directory /home/maurizio/salome_5.1.5/SMESH_5.1.5/lib/python2.4/site-packages/salome/salome is appended to sys.path

Traceback (most recent call last):

File "<input>", line 1, in ?

File "/home/maurizio/salome_5.1.5/KERNEL_5.1.5/lib/python2.4/site-packages/salome/import_hook.py", line 175, in import_hook

module= original_import(name, globals, locals, fromlist, *args, **kwds)

File "/home/maurizio/salome_5.1.5/KERNEL_5.1.5/lib/python2.4/site-packages/salome/import_hook.py", line 175, in import_hook

module= original_import(name, globals, locals, fromlist, *args, **kwds)

File "/home/maurizio/salome_5.1.5/SMESH_5.1.5/bin/salome/SMESH_box.py", line 59, in ?

alg1D = box_mesh.Segment()

File "/home/maurizio/salome_5.1.5/SMESH_5.1.5/bin/salome/smeshDC.py", line 1073, in Segment

return Mesh_Segment(self, geom)

File "/home/maurizio/salome_5.1.5/SMESH_5.1.5/bin/salome/smeshDC.py", line 4058, in __init__

self.Create(mesh, geom, "Regular_1D")

File "/home/maurizio/salome_5.1.5/SMESH_5.1.5/bin/salome/smeshDC.py", line 3972, in Create

algo = mesh.smeshpyD.CreateHypothesis(hypo, so)

File "/home/maurizio/salome_5.1.5/SMESH_5.1.5/bin/salome/smeshDC.py", line 900, in CreateHypothesis

return SMESH._objref_SMESH_Gen.CreateHypothesis(self, theHType, theLibName )

File "/home/maurizio/salome_5.1.5/SMESH_5.1.5/lib/python2.4/site-packages/salome/SMESH_Gen_idl.py", line 275, in CreateHypothesis

return _omnipy.invoke(self, "CreateHypothesis", _0_SMESH.SMESH_Gen._d_CreateHypothesis, args)

SALOME.SALOME_Exception: SALOME.SALOME_Exception(details=SALOME.ExceptionStruct(type=BAD_PARAM, text='Salome Exception : libgfortran.so.1: impossibile aprire il file oggetto condiviso: Nessun file o directory', sourceFile='/dn42/SALOME/series5x515/SMESH/Debian40-64/SMESH_SRC/src/SMESH_I/SMESH_Gen_i.cxx', lineNumber=452L))

>>>

 

I installed Salome platform following this instructions (worked with previous releases).

Attachments

Re: URGENT! mesh module problem

Posted by Christophe Bourcier at January 13. 2011

There is something wrong with your installation.

You'd better use the universal binaries 32 or 64 bits depending on your platform. It's lighter to download and faster to install.

Use the graphical installer if you want to compile Salome and its dependencies.

Don't install the binaries from the graphical installer if it doesn't exactly match your OS version.

 

Creating a link from another version of a library can lead to errors such the one you get.

Christophe

Re: URGENT! mesh module problem

Posted by jindi at March 12. 2011

Check this [url=http://www.livres-gratuits.fr/]Livres Gratuits[/url] i think its helpful for u...

Quick reply
URLs will be automatically hyperlinked. Basic HTML tags are OK.
Powered by Ploneboard
History
Activate by vaina on Jan 12, 2011 10:43 AM
Document Actions