Personal tools
You are here: Home Forum Install & build Salome Meca 6.6.0 with Arch Linux

Salome Meca 6.6.0 with Arch Linux

Up to Install & build

Salome Meca 6.6.0 with Arch Linux

Posted by Tobias Holzmann at April 03. 2013

Hi all,

i am trying to build Salome Meca on my new Arch Linux.

With the binarys I got several errors and with the whole code (1,7 GB) I can not execute the runInstall script. I always getting the following error:

[code][shor-ty@localhost InstallWizard_6.6.0_Mandriva_2010.0]$ python runInstall
  File "runInstall", line 23
    except Exception, an_exc:
                    ^
SyntaxError: invalid syntax

[/code]

Without python in the command line I get the same error.
Can someone help me or know what to do?

 

Thanks for reading and for help in advance

Tobi

Re: Salome Meca 6.6.0 with Arch Linux

Posted by Ricardo at April 03. 2013

Hi Tobi,

You should search in the forum as this question has already been answered:

http://www.salome-platform.org/forum/forum_9/572869342/108026602

 

 

Re: Salome Meca 6.6.0 with Arch Linux

Posted by Tobias Holzmann at April 07. 2013

Hi Richardo,

 

thanks for replaying but this is not working. I linked the python new and the setup is working till I came to the kernel modul. There I get errors...

Re: Salome Meca 6.6.0 with Arch Linux

Posted by Tobias Holzmann at April 08. 2013

Hi all,

I am getting the following error while compiling the source code (KERNEL) from git repository:

In file included from DF_Attribute.cxx:20:0:
DF_definitions.hxx: In constructor 'df_shared_ptr<T>::df_shared_ptr(const df_shared_ptr<Y>&;)':
DF_definitions.hxx:50:30: error: 'dynamic_cast_tag' is not a member of 'boost::detail'
       boost::shared_ptr<T>(r,boost::detail::dynamic_cast_tag())
                              ^
make[2]: *** [libDF_la-DF_Attribute.lo] Fehler 1
make[2]: Leaving directory `/home/shor-ty/Build/salome/src/KERNEL_SRC/src/DF'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/home/shor-ty/Build/salome/src/KERNEL_SRC/src'
make: *** [all-recursive] Fehler 1

 

While checking the system it seems that everything is okay:============================================================
Summary
============================================================

--- General mandatory products - Light configuration:
           cc : yes
      threads : yes
       python : yes
         swig : yes
         hdf5 : yes
       libxml : yes

--- CORBA mandatory products - default configuration:
      omniORB : yes
    omniORBpy : yes
        boost : yes

--- Kernel parallel extensions:
          mpi : no
         PaCO : no
   parallel_extension : no

--- Optional products:
    These products are optional because the KERNEL functions
    using them are built only if the products are detected.
      cppunit : yes
        numpy : yes
     libbatch : no

    Warning: Batch functions will not be available in
    Salome Launcher because they require libBatch.

--- Html documentation products: only required for doc production
      doxygen : yes
     graphviz : yes
     rst2html : yes
       sphinx : no


Default ORB   : omniORB



Does anybody knows how to fix that?
Tanks in advance T

Attachments
Powered by Ploneboard
Document Actions