Personal tools
You are here: Home Forum Install & build Salome 5.1.3 on Arch linux 64 bit

Salome 5.1.3 on Arch linux 64 bit

Up to Install & build

Salome 5.1.3 on Arch linux 64 bit

Posted by Tomislav Maric at May 02. 2010

Hello everyone,

I have tried to run the 64-bit binaries that run on Ubuntu, Fedora and other distributions but on my Arch linux machine I get the following error:

"Can not load application library "libSalomeApp.so":libXdamage.so.1:wrong ELF class:ELFCLASS64"


apart from the third party dependencies, my system versions of autoconf, gcc, etc. are different 
from the ones that are listed in the compilation instructions page. Is this a problem? 

I also can't seem to find the older versions for some of the third party software, is there a 
repo for salome somewhere where I can get all this stuff in one place? 

I'm using an AMD x84_64 HP Compaq 615 laptop... 

Re: Salome 5.1.3 on Arch linux 64 bit

Posted by Tomislav Maric at May 06. 2010

OK, nobody is answering.. :\ Maybe a more generic question: since the Salome source comes without the third party software, what would be the best way/procedure to follow if I want to compile it on Arch linux? I would really appreciate the help, in return I would build a package for this distribution :)

Any advice?

Re: Salome 5.1.3 on Arch linux 64 bit

Posted by Vincent at May 07. 2010

Hello Tomislav, I'm quite in the same situation than you, with Arch Linux and no working Salome package. I've been trying to compile it, but it's quite an impossible mission. The best I could find for now is the big 1.2GB package distributed on the download page, for example for mandriva. It comes with all sources of third party softwares, and with a wizard that is supposed to be managing the compilation and installation of all this. Unfortunately, I was not able to compile the outdated qt3 code of this wizard, even with the extra/qt3 package and the correct compiler options.

Good luck, and if you succeed, you'll make at least one other happy guy.

Re: Salome 5.1.3 on Arch linux 64 bit

Posted by Alex at June 14. 2010
Hi Vincent... be happy ... :D http://aur.archlinux.org/packages.php?O=0&K;=Salome&do;_Search=Go Only problem ( soon to be resolved ) Netgen plugin is not built yet... so no complicated geometries to mesh... YET... I am packing Code Saturne and Syrthes... BRGDS Alex

Re: Salome 5.1.3 on Arch linux 64 bit

Posted by Vincent at June 14. 2010

This is very good news Alex! Thanks for the hard work!

I'll test in the week. I'm new to Salome, it may take me some time to understand what all the packages/plugins exist for.

Re: Salome 5.1.3 on Arch linux 64 bit

Posted by Michele Mocciola at June 27. 2010

In the last days (26/6/2010) I made a lot of bugfixes on the packages available on AUR.

I report here the links:

salome-kernel - http://aur.archlinux.org/packages.php?ID=37841
salome-gui - http://aur.archlinux.org/packages.php?ID=37842
salome-geom - http://aur.archlinux.org/packages.php?ID=37843
salome-med - http://aur.archlinux.org/packages.php?ID=37845
salome-smesh - http://aur.archlinux.org/packages.php?ID=37844
salome-visu - http://aur.archlinux.org/packages.php?ID=37846
salome-yacs - http://aur.archlinux.org/packages.php?ID=37847
salome-netgenplugin - http://aur.archlinux.org/packages.php?ID=38496
salome-multipr - http://aur.archlinux.org/packages.php?ID=38497

If you find bugs or if you have ideas to improve them don't hesitate to send me a mail or leave a message on AUR.

Michele Mocciola aka mickele

Re: Salome 5.1.3 on Arch linux 64 bit

Posted by Vincent at June 27. 2010

Thanks Michele. I have been testing some package of the AUR since my last reply here. I was able to build the salome-kernel, but not the salome-gui, at first because of the bug I reported on the AUR page, and now because of the new version of the VTK dependency that I'm not able to build.

I'll take a look again in the week probably to see if there are changes on that. In the meantime I was able to compile FreeCAD also from AUR, so i'll maybe able to test both products :)

Greetings, Vincent

Re: Salome 5.1.3 on Arch linux 64 bit

Posted by Alex at June 30. 2010

Hi

 

Vtk builds easily...  only yacs, multipr and netgenplugin to go...

Tomorrow i will have news...

 

Salome-med takes quite long time to build...  :)

 

BRGDS

 

Alex

Re: Salome 5.1.3 on Arch linux 64 bit

Posted by Tobi Holzmann at April 03. 2013

Hi,

 

I am trying to use Salome on Arch LInux too.

Is there any possibilty to use the latest version ?

Powered by Ploneboard
Document Actions