Personal tools
You are here: Home Forum Install & build Salome 7.5.1 on Windows

Salome 7.5.1 on Windows

Up to Install & build

Salome 7.5.1 on Windows

Posted by aleory at April 11. 2015

Hi!

I installed Salome on Windows and when I launch run_salome.bat, it goes on until "Start SALOME, elapsed time : 0.0 seconds"

And then nothing else...

 

Does anyone have an idea of the solution to launch Salome in this case?

 

Many thanks,

 

Arnaud

Re: Salome 7.5.1 on Windows

Posted by diallo elhacen at May 29. 2015

Hi 

i  installed salome meca in windows  when i unzip  salome-7.5.1 -win64-DEV-RELEASE  it return to error .

please give somme about the usinng correctely salome meca

regards 

diallo.

Re: Salome 7.5.1 on Windows

Posted by Dussauj at June 30. 2015

Hello, I download Salome 7.5.1 win64 and I have the same problem than Arnaud.

The Salome start stop at "Start SALOME, elapsed time : 0.0 seconds"

Do you have a solution for this problem?

Thank you in advance,

 

 

Attachments

Re: Salome 7.5.1 on Windows

Posted by Dussauj at June 30. 2015

To complete my question, I have the same problem when I use Salome 7.5.1 win32

Re: Salome 7.5.1 on Windows

Posted by Raphael at August 12. 2015

I have the same problem, and hoped I could solve them with the new 7.6.1. for win64 (running win8.1). When I try to start salome by executing run_salome.bat I end up with:

 

runSalome running on ri

Process Process-1:

Traceback (most recent call last):

  File "C:\Users\richard\Downloads\SALOME-7.6.0-WIN64\PRODUCTS\python-2.7.3\Lib\

multiprocessing\process.py", line 258, in _bootstrap

    self.run()

  File "C:\Users\raphael\Downloads\SALOME-7.6.0-WIN64\PRODUCTS\python-2.7.3\Lib\

multiprocessing\process.py", line 114, in run

    self._target(*self._args, **self._kwargs)

  File "C:\Users\richard\Downloads\SALOME-7.6.0-WIN64\MODULES\KERNEL\bin\salome\

searchFreePort.py", line 128, in searchFreePort_withPortManager

    port = getPort(use_port)

  File "C:\Users\richard\Downloads\SALOME-7.6.0-WIN64\MODULES\KERNEL\bin\salome\

PortManager.py", line 120, in getPort

    config = pickle.load(f)

EOFError

 

I have seen this error before, but I have never been able to solve it ... any ideas?

Re: Salome 7.5.1 on Windows

Posted by Vadim SANDLER at August 12. 2015

Hello Raphael,

Please try the solution described in this topic: http://www.salome-platform.org/forum/forum_9/908814764 .

Regards,
Vadim.

Re: Salome 7.5.1 on Windows

Posted by Raphael at August 12. 2015

I did that already, which gets me stuck at starting salome at 33% and this terminal output:

runSalome running on ri

Searching for a free port for naming service: 2812 - OK

Searching Naming Service   found in 0.0 seconds

Searching /Kernel/Session in Naming Service +Warning, no type found for resource

 "localhost", using default value "single_machine"

++++++++++++++++++++++++++++++++++++++++++++++++++++++

 

 

Re: Salome 7.5.1 on Windows

Posted by Raphael at August 13. 2015

As I use windows I dont even have this line in my hosts file: 

"ip6-localhost ip6-loopback"

But I added a 

127.0.0.2 MYPCNAME

Line. Which did make the counter go further than 33%, but still salome does not start. It says now: 

"Waiting for session server ..."

Re: Salome 7.5.1 on Windows

Posted by Vadim SANDLER at August 14. 2015

Hmm.

I can suggest you to check your firewall settings. SALOME uses network protocols for interactation between different components so firewall can block its processes as suspicious. You might need to enable SALOME processes by adding them to the list of allowed programs/features in your firewall settings.

Regards,
Vadim.

Re: Salome 7.5.1 on Windows

Posted by Raphael at August 26. 2015

Hey Vadmin

Thanks for your help, but even the deactivated windows firewall does not help. The blue Salome window appears, with the message "waiting for Session Server ..." and the counter counts upwards, until 83% -> stops. Does nothing. Any more ideas?

Re: Salome 7.5.1 on Windows

Posted by Vadim SANDLER at August 26. 2015

Dunno. Virus protection software?

Try the following: edit run_salome.bat and replace "SET SALOME_VERBOSE=0" by "SET SALOME_VERBOSE=1", then start SALOME again. This should print some additional log into terminal window, maybe this will give any idea.

Re: Salome 7.5.1 on Windows

Posted by Raphael at August 26. 2015

LOTS of output :)

<font size = "4">Configure parser: processing C:\Users\raphael\Downloads\SALOME-7.6.0-WIN64\MODULES\GUI\share\salome\resources\gui\SalomeApp.xml ...

Configure parser: processing C:\Users\raphael\Downloads\SALOME-7.6.0-WIN64\MODULES\GUI\share\salome\resources\gui\LightApp.xml ...

Configure parser: user configuration file is C:\Users\raphael\.config\salome\SalomeApp.xml.7.4.0

Configure parser: processing C:\Users\raphael\.config\salome\SalomeApp.xml.7.4.0 ...

Configure parser: processing C:\Users\raphael\Downloads\SALOME-7.6.0-WIN64\MODULES\GUI\share\salome\resources\gui\SalomeApp.xml ...

Configure parser: processing C:\Users\raphael\Downloads\SALOME-7.6.0-WIN64\MODULES\GUI\share\salome\resources\gui\LightApp.xml ...

Configure parser: processing C:\Users\raphael\Downloads\SALOME-7.6.0-WIN64\MODULES\PARAVIS\share\salome\resources\paravis\SalomeApp.xml ...

Configure parser: processing C:\Users\raphael\Downloads\SALOME-7.6.0-WIN64\MODULES\YACS\share\salome\resources\yacs\SalomeApp.xml ...

Configure parser: processing C:\Users\raphael\Downloads\SALOME-7.6.0-WIN64\MODULES\MED\share\salome\resources\med\SalomeApp.xml ...

Configure parser: processing C:\Users\raphael\Downloads\SALOME-7.6.0-WIN64\MODULES\HEXABLOCK\share\salome\resources\hexablock\SalomeApp.xml ...

Configure parser: processing C:\Users\raphael\Downloads\SALOME-7.6.0-WIN64\MODULES\SMESH\share\salome\resources\smesh\SalomeApp.xml ...

Configure parser: processing C:\Users\raphael\Downloads\SALOME-7.6.0-WIN64\MODULES\GEOM\share\salome\resources\geom\SalomeApp.xml ...

Configure parser: processing C:\Users\raphael\Downloads\SALOME-7.6.0-WIN64\MODULES\GUI\share\salome\resources\gui\SalomeApp.xml ...

Configure parser: processing C:\Users\raphael\Downloads\SALOME-7.6.0-WIN64\MODULES\GUI\share\salome\resources\gui\LightApp.xml ...

Configure parser: user configuration file is C:\Users\raphael\.config\salome\SalomeApp.xml.7.4.0

Configure parser: processing C:\Users\raphael\.config\salome\SalomeApp.xml.7.4.0 ...

runSalome running on ra

Searching for a free port for naming service: 2815 - OK

startSalome  {u'SMESH_documentation': u'smesh_help', u'YACS_stream_link_draw_color': u'192, 192,   0', u'SMESH_info_dump_ctrl': u'true', u'SMESH_incremental_limit': u'false', u'HEXABLOCK_documentation': u'hexablock_help', 'port': '2815', u'

GEOM_documentation': u'geom_help', u'GEOM_version': u'7.6.0', u'SMESH_outline_color': u'#004600', u'YACS_CtrlPort_Height': u'25', u'SMESH_historical_python_dump': u'false', u'SMESH_scalar_bar_horizontal_x': u'0.1', u'SMESH_scalar_bar_horizontal_y': u'0.01', u'SMESH_selection_element_color': u'255, 255,   0', u'SMESH_ma

rker_scale': u'9', u'YACS_icon': u'ModuleYacs.png', u'SMESH_version': u'7.6.0',u'YACS_simplifyLink': u'false', u'YACS_ACTIVATED': u'#000080', u'YACS_name': u'YACS', u'SMESH_orientation_color': u'255, 255, 255', u'YACS_CtrlPort_Width': u'8

', u'MED_documentation': u'med_help', u'YACS_DataPort_hiPen': u' 11, 128,   0', u'SMESH_show_result_notification': u'2', u'logger': False, u'SMESH_ball_elem_scale': u'1', u'YACS_DataStreamPort_brush': u'158, 227, 151', u'SMESH_wireframe_color': u'0, 170, 255', u'xterm': False, u'YACS_progressBarLabel': u'2', u'SMESH_ou

tline_width': u'1', u'SMESH_mesh_elem_info': u'1', u'YACS_control_link_select_color': u'255, 192, 255', u'SMESH_default_grp_color': u'255, 170, 0', 'gdb_session': False, u'YACS_DISABLED': u'255, 170, 0', u'SMESH_vol_precision': u'-6', u'YACS_Scene_hiBrush': u'190, 190, 190', u'YACS_STOPPED': u'255, 205, 243', u'YACS_El

ementaryNode_hiBrush': u'209, 255, 205', u'gui': True, u'SMESH_auto_update': u'true', u'YACS_RUNNING': u'205, 255, 218', u'YACS_userCatalog': u'YACSUserCatalog.xml', u'SMESH_scalar_bar_num_colors': u'64', u'YACS_DONE': u'#008000', u'SMESH_forget_mesh_on_hyp_modif': u'true', u'YACS_ERROR': u'255, 0, 0', u'GEOM_icon': u'

ModuleGeom.png', u'SMESH_scalar_bar_label_color': u'255, 255, 255', u'SMESH_selection_precision_object': u'0.005', 'foreground': 1, u'SMESH_max_angle': u'2', u'YACS_UNDEFINED': u'#c0c0c0', u'interp': 0, u'YACS_CtrlPort_hiPen': u' 60,  60, 60', u'YACS_WAITINGTASKS': u'205, 255, 255', 'valgrind_session': False, u'SMESH_

volume_color': u'#ff00aa|-100', u'HEXABLOCK_icon': u'ModuleHexablock.png', u'YACS_autoComputeLinks': u'true', u'SMESH_icon': u'ModuleMesh.png', u'YACS_PAUSED': u'205, 218, 255', u'YACS_ComposedNode_hiPen': u' 60,  60,  60', u'YACS_Header_hiBrush': u'161, 178, 238', u'SMESH_info_dump_add': u'true', u'SMESH_preview_color': u'#00ff00|-100', 'user_config': 'C:\\Users\\raphael\\.config\\salome\\SalomeApp.xml.7.4.0', u'YACS_validNodeColor': u'128, 255, 128', u'SMESH_scalar_bar_hori

zontal_height': u'0.08', u'SMESH_len_tol_precision': u'-7', u'SMESH_info_groups_nodes_limit': u'100000', u'YACS_stream_link_select_color': u'255, 255, 192', u'HEXABLOCK_name': u'HexaBlock', u'SMESH_node_color': u'255, 0,   0', u'SMESH_scalar_bar_title_color': u'255, 255, 255', u'YACS_FINISHED': u'230, 205, 255', u'SMES

H_fill_color': u'#00aaff|100', u'YACS_TOLOAD': u'#808000', u'YACS_emphasizeBrushColor': u'  0, 255,   0', u'YACS_addRowCols': u'false', 'pyscript': [], u'YACS_documentation': u'yacs_help', u'HEXABLOCK_version': u'7.6.0', u'key': [u'no'], u'MED_name': u'MED', u'SMESH_use_precision': u'false', u'SMESH_group_name_color':

u'255, 255, 255', u'YACS_LOADFAILED': u'255, 0, 170', 'wake_up_session': False,u'SMESH_info_dump_elem': u'true', u'standalone': [], u'YACS_link_pen_darkness': u'150', u'SMESH_numbering_elem_color': u'0, 255, 0', u'YACS_Scene_hiPen': u'  0,   0, 190', u'YACS_invalidNodeColor': u'255, 128, 128', u'SMESH_selection_object

_color': u'255, 255, 255', u'YACS_tabPanelsUp': u'true', u'YACS_INTERNALERR': u'255, 0, 85', u'pyModules': u'', u'SMESH_orientation_scale': u'0.1', u'YACS_NOTYETINITIALIZED': u'255, 243, 205', 'plugins': [], u'SMESH_numbering_elem_font': u'Times,Bold,12', u'SMESH_auto_groups': u'false', u'SMESH_update_limit': u'500000'

, u'SMESH_ball_elem_size': u'10', u'YACS_DataStreamPort_hiBrush': u'127, 227, 116', u'MED_library': u'MEDOPGUI', u'YACS_CtrlPort_hiBrush': u'161, 176, 227', u'YACS_link_thickness': u'1', u'YACS_font': u'Courier,9', u'YACS_DataPort_hiBrush': u'127, 227, 116', u'SMESH_scalar_bar_vertical_width': u'0.08', u'SMESH_display_

mode': u'1', u'YACS_DESACTIVATED': u'#a0a0a4', u'SMESH_name': u'Mesh', u'SMESH_equal_nodes_tolerance': u'1e-7', u'SMESH_length_precision': u'-6', u'YACS_editedNodeBrushColor': u'255, 255, 190', u'MED_icon': u'MEDOP.png', 'appname': 'SalomeApp', u'SMESH_scalar_bar_vertical_x': u'0.01', u'SMESH_selection_precision_node':

 u'0.005', u'SMESH_renumbering': u'false', u'SMESH_area_precision': u'-6', u'SMESH_nb_segments_per_edge': u'15', u'splash': True, u'SMESH_scalar_bar_horizontal_width': u'0.8', 'shutdown_servers': 0, u'YACS_link_separation_weight': u'10', u'YACS_Header_brush': u'215, 220, 238', u'SMESH_info_dump_base': u'true', u'portki

ll': False, 'save_config': True, u'SMESH_scalar_bar_title_font': u'Arial,12', u'SMESH_segmentation': u'10', u'SMESH_scalar_bar_vertical_height': u'0.8', u'SMESH_selection_precision_element': u'0.005', u'YACS_UNKNOWN': u'255, 205, 205', u'YACS_TOACTIVATE': u'#008080', u'SMESH_ball_elem_diameter': u'1', u'YACS_dragOver':

 u'255,   0,   0', u'YACS_progressBarColor': u'#008000', u'YACS_SUSPENDED': u'#a0a0a4', 'study_hdf': None, u'SMESH_controls_precision': u'0', u'YACS_ComposedNode_hiBrush': u'225, 225, 225', u'SMESH_scalar_bar_num_labels': u'5', u'SMESH_distribution_coloring_type': u'0', u'embedded': [u'SalomeAppEngine', u'study', u'cpp

Container', u'registry', u'moduleCatalog'], u'YACS_Scene_pen': u'  0,   0, 128', u'YACS_INVALID': u'255, 0, 0', u'YACS_PAUSE': u'0, 255, 255', u'YACS_COMPONENT_INSTANCE_NEW': u'true', u'YACS_DataPort_pen': u' 15, 180,   0', u'SMESH_elem0d_color': u'0, 255,   0', 'batch': False, u'SMESH_parametric_precision': u'-6', u'S

MESH_elem0d_size': u'5', u'SMESH_distribution_color': u'0, 85, 0', u'YACS_Header_hiPen': u' 60,  60,  60', u'YACS_link_draw_color': u'  0,   0, 192', u'YACS_READY': u'#a0a0a4', u'MED_version': u'7.6.0', 'ddd_session': False, u'YACS_ElementaryNode_pen': u' 15, 180,   0', u'YACS_DEFAULT': u'#c0c0c0', u'YACS_CtrlPort_pen'

: u'120, 120, 120', u'SMESH_scalar_bar_vertical_y': u'0.1', u'SMESH_scalar_bar_orientation': u'1', u'SMESH_element_width': u'1', u'YACS_DataPort_brush': u'158,227, 151', u'YACS_normalNodeBrushColor': u'230, 235, 255', u'YACS_LOADED': u'#800080', u'SMESH_numbering_node_color': u'255, 255, 255', u'file': False, u'SMESH_

highlight_color': u'0, 255, 255', u'SMESH_distribution_visibility': u'false', u'SMESH_ball_elem_color': u'0, 85,   255', u'PARAVIS_show_color_legend': u'0', u'SMESH_display_entity': u'true', u'YACS_control_link_draw_color': u'192,   0, 192', u'YACS_Header_pen': u'120, 120, 120', u'SMESH_numbering_node_font': u'Times,Bo

ld,10', u'PARAVIS_name': u'ParaViS', u'YACS_CtrlPort_brush': u'205, 210, 227', u'YACS_link_select_color': u'192, 192, 255', u'YACS_DataStreamPort_hiPen': u' 11, 128,   0', u'killall': False, u'YACS_EXECFAILED': u'255, 85, 0', u'YACS_INITIALISED': u'230, 255, 205', 'session_gui': True, u'SMESH_angle_precision': u'-3', u

'YACS_ComposedNode_brush': u'213, 213, 213', u'YACS_version': u'7.6.0', u'SMESH_preview_actor_chunk_size': u'100', u'pinter': False, u'PARAVIS_icon': u'pqAppIcon22.png', u'SMESH_type_of_marker': u'1', u'YACS_ElementaryNode_brush': u'189, 230, 185', u'PARAVIS_version': u'7.6.0', u'YACS_FAILED': u'255, 85, 0', u'YACS_Dat

aPort_Height': u'25', u'SMESH_info_controls_limit': u'3000', u'YACS_Scene_brush': u'128, 128, 128', u'YACS_ElementaryNode_hiPen': u' 11, 128,   0', u'SMESH_elem_info_grp_details': u'false', u'SMESH_DisplayMode': u'true', u'SMESH_shrink_coeff': u'75', u'YACS_ensureVisibleWhenMoved': u'true', u'PARAVIS_singleton': u'true

', u'YACS_DataPort_Width': u'100', u'SMESH_orientation_3d_vectors': u'false', u'SMESH_quadratic_mode': u'0', u'modules': [u'GEOM', u'SMESH', u'HEXABLOCK', u'MED', u'YACS', u'PARAVIS'], u'YACS_ComposedNode_pen': u'120, 120, 120', u'SMESH_scalar_bar_label_font': u'Arial,12', u'YACS_runNodeBrushColor': u'205, 218, 255', u

'SMESH_def_precision': u'3', u'GEOM_name': u'Geometry', u'YACS_DataStreamPort_pe

n': u' 15, 180,   0', u'noexcepthandler': False}

Launch Naming Service++ Name Service...  ss =  ['NameService=corbaname::ra:2815'] ... ok

to list contexts and objects bound into the context with the specified name : showNS

######## win32pm.spwanpid cmd =  ['omniNames', '-start', '2815', '-nohostname','-logdir', 'c:\\users\\raphael\\appdata\\local\\temp\\logs\\raphael\\omniNames_2815', '-errlog', 'c:\\users\\raphael\\appdata\\local\\temp\\logs\\raphael\\omniNames_2815\\omniNameErrors.log']

######## win32pm.spwanpid option =  -nc

######## win32pm.spwanpid pid =  4380

Searching Naming Service   found in 0.0 seconds

######## win32pm.spwanpid cmd =  ['SALOME_Session_Server', '--with', 'Registry', '(', '--salome_session', 'theSession', ')', '--with', 'ModuleCatalog', '(', '-common', u'"C:\\Users\\raphael\\Downloads\\SALOME-7.6.0-WIN64\\MODULES\\KERNEL\\share\\salome\\resources\\kernel\\KERNELCatalog.xml"::"C:\\Users\\raphael\\Downlo

ads\\SALOME-7.6.0-WIN64\\MODULES\\GEOM\\share\\salome\\resources\\geom\\GEOMCatalog.xml"::"C:\\Users\\raphael\\Downloads\\SALOME-7.6.0-WIN64\\MODULES\\SMESH\\share\\salome\\resources\\smesh\\SMESHCatalog.xml"::"C:\\Users\\raphael\\Downloads\\SALOME-7.6.0-WIN64\\MODULES\\HEXABLOCK\\share\\salome\\resources\\hexablock\\H

EXABLOCKCatalog.xml"::"C:\\Users\\raphael\\Downloads\\SALOME-7.6.0-WIN64\\MODULES\\MED\\share\\salome\\resources\\med\\MEDCatalog.xml"::"C:\\Users\\raphael\\Downloads\\SALOME-7.6.0-WIN64\\MODULES\\YACS\\share\\salome\\resources\\yacs\\YACSCatalog.xml"::"C:\\Users\\raphael\\Downloads\\SALOME-7.6.0-WIN64\\MODULES\\PARAVI

S\\share\\salome\\resources\\paravis\\PARAVISCatalog.xml"', '-personal', 'C:\\Users\\raphael\\Salome/resources/CatalogModulePersonnel.xml', ')', '--with', 'SALOMEDS', '(', ')', '--with', 'Container', '(', 'FactoryServer', ')', '--with', 'SalomeAppEngine', '(', ')', 'CPP', 'GUI', 'SPLASH', '--resources=C:\\Users\\raphae

l\\.config\\salome\\SalomeApp.xml.7.4.0', u'--modules (GEOM:SMESH:HEXABLOCK:MED:YACS:PARAVIS)']

######## win32pm.spwanpid option =  -nc

######## win32pm.spwanpid pid =  3456

######## win32pm.spwanpid cmd =  ['SALOME_LauncherServer', '--with', 'Registry', '(', '--salome_session', 'theSession', ')', '--with', 'ModuleCatalog', '(', '-common', u'"C:\\Users\\raphael\\Downloads\\SALOME-7.6.0-WIN64\\MODULES\\KERNEL\\share\\salome\\resources\\kernel\\KERNELCatalog.xml"::"C:\\Users\\raphael\\Downlo

ads\\SALOME-7.6.0-WIN64\\MODULES\\GEOM\\share\\salome\\resources\\geom\\GEOMCatalog.xml"::"C:\\Users\\raphael\\Downloads\\SALOME-7.6.0-WIN64\\MODULES\\SMESH\\share\\salome\\resources\\smesh\\SMESHCatalog.xml"::"C:\\Users\\raphael\\Downloads\\SALOME-7.6.0-WIN64\\MODULES\\HEXABLOCK\\share\\salome\\resources\\hexablock\\H

EXABLOCKCatalog.xml"::"C:\\Users\\raphael\\Downloads\\SALOME-7.6.0-WIN64\\MODULES\\MED\\share\\salome\\resources\\med\\MEDCatalog.xml"::"C:\\Users\\raphael\\Downloads\\SALOME-7.6.0-WIN64\\MODULES\\YACS\\share\\salome\\resources\\yacs\\YACSCatalog.xml"::"C:\\Users\\raphael\\Downloads\\SALOME-7.6.0-WIN64\\MODULES\\PARAVI

S\\share\\salome\\resources\\paravis\\PARAVISCatalog.xml"', '-personal', '${HOME}/Salome/resources/CatalogModulePersonnel.xml', ')', '--with', 'SALOMEDS', '(',')', '--with', 'Container', '(', 'FactoryServer', ')']

######## win32pm.spwanpid option =  -nc

######## win32pm.spwanpid pid =  5396

######## win32pm.spwanpid cmd =  ['SALOME_ConnectionManagerServer']

######## win32pm.spwanpid option =  -nc

######## win32pm.spwanpid pid =  5028

Searching /Kernel/Session in Naming Service +Warning, no type found for resource

 "localhost", using default value "single_machine"

++++++++++++++++++++++++++++++++++++++++++++++++++++

</font>

Re: Salome 7.5.1 on Windows

Posted by Vadim SANDLER at August 27. 2015

But nothing suspicious in the output.

Probably this is a problem specific for Windows 8. In fact, SALOME was not qualified on Windows 8.

I'll try to launch SALOME 7.6.0 on Windows 8 to see if I can reproduce this problem.

Re: Salome 7.5.1 on Windows

Posted by Raphael at September 03. 2015

Did you find anything, that could help me?

Re: Salome 7.5.1 on Windows

Posted by Vadim SANDLER at September 10. 2015

Nothing, sorry. On my side, SALOME 7.6.0 is well running on Windows 8.

In addition to already mentioned possible reasons while SALOME cannot be running, there's another known issue imposed by the Windows architecture.

In short, on Windows search order for shared libraries is implemented as follows:

* The directory where program is situated;
* Windows system directory;
* PATH env variable.

This is quite different to Linux where LD_LIBRARY_PATH has top-most priority.

SALOME consists of very large set of libraries, including third-party products. These libraries are distributed between different directories (in fact, each product and SALOME module is installed into separate directory). Search path for libraries is set in the launching script via setting environment variables, in particular, PATH on Windows (LD_LIBRARY_PATH on Linux). I think you already see the possible problem on Windows - if some product being used by SALOME is also present on the workstation (e.g. it is installed with some other application) and libraries are installed into Window's system directory - you might get undefined symbols or other similar problem preventing correct SALOME work, due to incompatibility of product's version installed into system directory and coming with SALOME.

Note that this is just a possible trouble, I don't guarantee it is your case. Actually this case is quite rare. It is, unfortunately, not easy to diagnose this problem. I hoped something could be printed into output log but did not see anything suspicious. Further analysis would require installing, for instance, Microsoft Dependency Walker and analyzing dependency of the libraries, etc.

Re: Salome 7.5.1 on Windows

Posted by Raphael at September 10. 2015

yeah I already thought about the dependency walker but assumed it would not be of much help as it usually shows things the executable needs when starting up. I could give it a try tough.

Re: Salome 7.5.1 on Windows

Posted by Yann Caniou at November 09. 2015

Hello everyone,

I'm actually facing a similar problem trying to run SalomeMeca 7.6.0 on Windows 7 :

When running run_salome.bat, the blue screen appears and te progressbar increases until 33% or 83% and then stops. On the command window behind is the following message:

"""

runSalome running on NO-NB-YC

Searching for a free port for naming service: 2820 - OK

Searching Naming Service found in 0.0 seconds

Searching /Kernel/Session in Naming Service +Warning, no type found for ressource "localhost", using default value "single machine"

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

"""

i also tried to execute the envSalome.py and runSalome.py files and it says that it is unable to find omniORB:

no module named omniORB

I downloaded omniORB from sourceforge and built it using cygwin and MS Visual Studio 14 but it did not solve the issue.

I think there is a problem with the naming service. Or maybe something else.

I am not very familiar with Windows so any help would be great !

Thanks!

Yann

 

Re: Salome 7.5.1 on Windows

Posted by sweety2142 at February 03. 2016

I resolved

Re: Salome 7.5.1 on Windows

Posted by Daniel Potter at April 13. 2017

I'm having the same problem that Raphael mentioned above:

"waiting for Session Server ..." and the counter counts upwards, until 83% -> stops.

 

is there a solution?

 

thank-you

Re: Salome 7.5.1 on Windows

Posted by Allan Yan at April 16. 2017

Previously aleory wrote:

Hi, could you please share instructions of installation of salome on win7?

Many thanks.

Allan

Hi!

I installed Salome on Windows and when I launch run_salome.bat, it goes on until "Start SALOME, elapsed time : 0.0 seconds"

And then nothing else...

 

Does anyone have an idea of the solution to launch Salome in this case?

 

Many thanks,

 

Arnaud

 

Re: Salome 7.5.1 on Windows

Posted by Emma Wang at April 21. 2017

Hi,

      Did you solve the problem? I met the exactly same problem, and I still don't know how to deal with it.

 

Previously aleory wrote:

Hi!

I installed Salome on Windows and when I launch run_salome.bat, it goes on until "Start SALOME, elapsed time : 0.0 seconds"

And then nothing else...

 

Does anyone have an idea of the solution to launch Salome in this case?

 

Many thanks,

 

Arnaud

 

Re: Salome 7.5.1 on Windows

Posted by Daniel Potter at October 30. 2017

No problem persists in 8.3.0.  Solution is to use Linux instead of windows....

Powered by Ploneboard
Document Actions