Personal tools
You are here: Home Forum Install & build Trouble while running Salome 6.5.0 in Ubuntu 12.04

Trouble while running Salome 6.5.0 in Ubuntu 12.04

Up to Install & build

Trouble while running Salome 6.5.0 in Ubuntu 12.04

Posted by Hao BAI at July 04. 2012

Hello,

I've installed successfully Salome in my computer ( OS Ubuntu 12.04). But when I execute the Salome, it is stopped by some errors that I cannot understand :

hp@ubuntu:~$ /home/hp/salome/appli_V6_5_0p1/runAppli


runSalome running on ubuntu

Searching for a free port for naming service: 2810 - OK

Searching Naming Service + found in 0.1 seconds 

Searching /Containers/ubuntu/FactoryServerPy in Naming Service ++++++X Error of failed request:  BadRequest (invalid request code or no such operation)

  Major opcode of failed request:  154 (GLX)

  Minor opcode of failed request:  19 (X_GLXQueryServerString)

  Serial number of failed request:  13

  Current serial number in output stream:  13

 found in 3.0 seconds 

Traceback (most recent call last):

  File "/home/hp/salome/appli_V6_5_0p1/bin/salome/runSalome.py", line 684, in useSalome

    clt = startSalome(args, modules_list, modules_root_dir)

  File "/home/hp/salome/appli_V6_5_0p1/bin/salome/runSalome.py", line 629, in startSalome

    session=clt.waitNSPID("/Kernel/Session",mySessionServ.PID,SALOME.Session)

  File "/home/hp/salome/Salome-V6_5_0p1-LGPL-i686/modules/KERNEL_V6_5_0p1/bin/salome/orbmodule.py", line 170, in waitNSPID

    raise RuntimeError, "Process %d for %s not found" % (thePID,theName)

RuntimeError: Process 2147 for /Kernel/Session not found

Searching /Kernel/Session in Naming Service 


--- Error during Salome launch ---

 

The Salome is installed in the directory /home/hp/salome. I'm new in Ubuntu and it's my first time to use Salome cause I need it in my internship. It's really be thankful if someone can help me to solve this problem as soon as possible.

Thank you a lot !

 

-----------------------------------------------------------------

Bonjour à toutes/tous,

J'avis réussi l'installation de Salome 6.5.0 dans mon pc (Ubuntu 12.04). Mais j'ai rencontré des problèmes quand je lance le programme. Voici les erreurs affichés dans le terminal:

(veuillez regarder les instructions en gras ci-dessus)

Je comprends rien du tout sur ces erreurs et le Salome est installé dans sous le répertoire /home/hp/salome dans mon pc. C'est ma première fois d'utiliser ce logiciel à cause de mon stage dans entreprise. Je vous remercie par avance pour votre aide.

Cordialement

Re: Trouble while running Salome 6.5.0 in Ubuntu 12.04

Posted by DAVID Gilles at July 04. 2012

Hello,

This seems to be a problem with your graphic drivers. 

Please try to install the ATI proprietary drivers (through System parameters / Proprietary drivers)

Regards,

Gilles

Re: Trouble while running Salome 6.5.0 in Ubuntu 12.04

Posted by Hao BAI at July 04. 2012

Previously DAVID Gilles wrote:

Hello,

This seems to be a problem with your graphic drivers. 

Please try to install the ATI proprietary drivers (through System parameters / Proprietary drivers)

Regards,

Gilles

 

 

Thank you ! I've solved the problem. Just like you said, the problem is caused by the graphic card driver.
 
Now, I wonder if it's possible to install the Code_Aster module in the Salomé ? In fact, my topic of internship is about to modelise the propagation of crack by using Code_Aster. And I've learned that all the fonctions in Salomé are installed by the forme of module like Mesh, Geo and so on. So could you tell me how I can intall the Code_Aster module in the Salomé ?
 
Thanks again.

Re: Trouble while running Salome 6.5.0 in Ubuntu 12.04

Posted by DAVID Gilles at July 04. 2012

If you want to run Code_Aster, then you should download Salome_Meca, which is just Salome + Code_Aster.

Here is the webpage: http://www.code-aster.org/V2/spip.php?article295

Regards,

Gilles

 

Re: Trouble while running Salome 6.5.0 in Ubuntu 12.04

Posted by Hao BAI at July 05. 2012

Previously DAVID Gilles wrote:

If you want to run Code_Aster, then you should download Salome_Meca, which is just Salome + Code_Aster.

Here is the webpage: http://www.code-aster.org/V2/spip.php?article295

Regards,

Gilles

 

 

 

Yes, in fact, I've installed successfully Salome-Meca-2010.2 in my computer (Ubuntu 12.04 32bit). But when I execute it, it is stopped by some errors that I cannot understand :
 
P.S. The Salome-Meca is installed in the directory /home/hp/SALOME-MECA-2010.2-LGPL-i386.
 
--------------------------------- x --------------------------------- x --------------------------------- x --------------------------------- x -----------------------------
      hp@ubuntu:~/SALOME-MECA-2010.2-LGPL-i386$ ./runSalomeMeca
 
      python: relocation error: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
      python: relocation error: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
      python: relocation error: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
      dirname: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by dirname)
      python: relocation error: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
      /bin/bash: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: version `GLIBC_2.11' not found (required by /bin/bash)
      /bin/bash: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: version `GLIBC_2.8' not found (required by /bin/bash)
      /bin/bash: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: version `GLIBC_2.15' not found (required by /bin/bash)
      /bin/bash: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /bin/bash)
      /bin/bash: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /lib/i386-linux-gnu/libtinfo.so.5)
--------------------------------- x --------------------------------- x --------------------------------- x --------------------------------- x -----------------------------
 
I'm sure that i've installed libc6 on my computer. According to these descriptions, it seems that I need a program named GLIBC ?? Buy I never find a program named like this in Ubuntu.
 
Can you help me with this ?
 
Regards

Re: Trouble while running Salome 6.5.0 in Ubuntu 12.04

Posted by DAVID Gilles at July 05. 2012

OK I see. You installed a quite old version of SALOME_MECA.

In this version, the directory Prerequis/etchForSalome/ is not up to date.

Please see this post to fix the problem.

Regards,

Gilles

Re: Trouble while running Salome 6.5.0 in Ubuntu 12.04

Posted by Hao BAI at July 05. 2012

Previously DAVID Gilles wrote:

OK I see. You installed a quite old version of SALOME_MECA.

In this version, the directory Prerequis/etchForSalome/ is not up to date.

Please see this post to fix the problem.

Regards,

Gilles

 

 

Is it possible to install the latest SALOME_MECA in a 32bit system ??? Cause I see there's only one version for 32bit system on the download page. It seems that I've no choice except I change my OS in 64bit.

Re: Trouble while running Salome 6.5.0 in Ubuntu 12.04

Posted by DAVID Gilles at July 05. 2012

I'm afraid that the SALOME_MECA team abandoned the delivery of the 32 bits version of Code_Aster after the version 2010.2.

Unfortunately, it is not so easy to plug the Aster module (and its prerequisites) directly into Salome.

For a quick fix of your problem, see my previous post (it is easy to do).

For a long term use of SALOME_MECA I suggest you to switch indeed to a 64 bits OS.

Regards,

Gilles

 

 

Re: Trouble while running Salome 6.5.0 in Ubuntu 12.04

Posted by Hao BAI at July 05. 2012

Previously DAVID Gilles wrote:

I'm afraid that the SALOME_MECA team abandoned the delivery of the 32 bits version of Code_Aster after the version 2010.2.

Unfortunately, it is not so easy to plug the Aster module (and its prerequisites) directly into Salome.

For a quick fix of your problem, see my previous post (it is easy to do).

For a long term use of SALOME_MECA I suggest you to switch indeed to a 64 bits OS.

Regards,

Gilles

 

 Thanks for all your help ! Finally, it works on my computer :) I'll discuss your recommandation with my supervisor. 

 

Best regards.

Re: Trouble while running Salome 6.5.0 in Ubuntu 12.04

Posted by Hao BAI at July 05. 2012

 Hi, 

 

It's me again. ;) Thanks to your recommandation, I've reinstalled my OS in 64bit and the latest SALOME-MECA. All seems OK except that I get some warnings when I run it. Here is the lien concern the warnings and I think maybe you know how to solve it :
 
 
Regards

Re: Trouble while running Salome 6.5.0 in Ubuntu 12.04

Posted by DAVID Gilles at July 05. 2012

Good :)

Re: Trouble while running Salome 6.5.0 in Ubuntu 12.04

Posted by josef roider at August 22. 2012

Previously DAVID Gilles wrote:

Please try to install the ATI proprietary drivers (through System parameters / Proprietary drivers)

 

Hello,

 

I had the same problem. However, solving it, was not as straight forward as I thought. Neither the fglrx nor the fglrx-updates driver from the distribution packages solve the error above.

 

I succeeded finally by downloading and installing the driver from

http://support.amd.com/us/gpudownload/linux/Pages/radeon_linux.aspx

 

But attention: direct installation breaks the x-server which you'd probably want to avoid!

 

It finally worked by generating and installing the distribution specific packages (which may conveniently also be done with the installer downloaded from the AMD website). You'll have, however, also to install some programs for deb-package building which are not normally part of a standard installation. You can see the required programs from the error messages in the log file of the installer via e.g. cat /usr/share/ati/fglrx-install.log.

 

Regards

 

 

Re: Trouble while running Salome 6.5.0 in Ubuntu 12.04

Posted by DAVID Gilles at August 22. 2012

Hello,

Thank you for your feedback.

It is a pity to face such problems only because you have an ATI based computer.

Best regards,

Gilles

Powered by Ploneboard
Document Actions