Personal tools
You are here: Home Forum Install & build Arch Linux - GUI library corresponding to the user action cannot be found or loaded

Arch Linux - GUI library corresponding to the user action cannot be found or loaded

Up to Install & build

Arch Linux - GUI library corresponding to the user action cannot be found or loaded

Posted by Miguel Segade at September 17. 2017

Hi

I've installed Salome 8.3 in Arch linux using the universal binaries. Because Arch uses python3 as default, I had to change a couple of lines from python to python2 in the create_appli_V8_3_0.sh script, but the installation finished without errors.

All the modules seem to be working fine, but in the GUI module I have this error while trying to use some of the functions (explode, 2D sketch, 3D sketch...):

"GUI library corresponding to the user action cannot be found or loaded"

I've seen this post where the same problem seems to be fixed for the windows version but still no luck in Arch Linux: http://www.salome-platform.org/forum/forum_9/489620500/view

Any ideas?

Thanks for the help

Re: Arch Linux - GUI library corresponding to the user action cannot be found or loaded

Posted by Bernd_R at November 17. 2017

Hi Miguel,

I am trying to install Salome on Manjaro/Arch but the packages in AUR are broken and the Universal binaries do not work (tried to fix the python issue). I would compile it myself but I cannot find a guide to do it. The sources are available over git (found the link after searching for it for way too long), but there is no mention about the projects I need to clone to get a full blown Salome up and running.

This is really exhausting at the moment.

Do you have made any progress?

Re: Arch Linux - GUI library corresponding to the user action cannot be found or loaded

Posted by Mario Storti at November 17. 2017

Previously Bernd_R wrote:

Hi Miguel,

I am trying to install Salome on Manjaro/Arch but the packages in AUR are broken and the Universal binaries do not work (tried to fix the python issue). I would compile it myself but I cannot find a guide to do it. The sources are available over git (found the link after searching for it for way too long), but there is no mention about the projects I need to clone to get a full blown Salome up and running.

This is really exhausting at the moment.

Do you have made any progress?

 

Hi Bernd_R,

 

I have the same problem on Fedora 26, reported here http://www.salome-platform.org/forum/forum_9/381742558
 
This thread: http://www.salome-platform.org/forum/forum_9/501687786 also seems to be closely related. 
 
It seems that there is no solution to this issue so far :)
 
Regards, Mario
 
Powered by Ploneboard
Document Actions