Personal tools
You are here: Home Forum Install & build Cannot run Salome-meca 2012.1 on Ubuntu 11.10

Cannot run Salome-meca 2012.1 on Ubuntu 11.10

Up to Install & build

Cannot run Salome-meca 2012.1 on Ubuntu 11.10

Posted by Thibaut at March 30. 2012

Hello,

 

I downloaded Salome-meca 2012.1 on

 

http://www.code-aster.org/FICHIERS/SALOME-MECA-2012.1-LGPL.tgz

 

I Extracted the files in home/usr/bin/Salome

Then i executed postinstall, everything seemed to go well : lots of OK.

When i execute runSalomeMeca in terminal i get this message.

 

./runSalomeMeca: line 50: /home/thibaut/usr/bin/SALOME-MECA-2012.1-LGPL/SALOME/Salome-V6_4_0-x86_64/prerequisites/Python_266/bin/python: cannot execute binary file

KERNEL_ROOT_DIR=/home/thibaut/usr/bin/SALOME-MECA-2012.1-LGPL/appli

/home/thibaut/usr/bin/SALOME-MECA-2012.1-LGPL/SALOME/Salome-V6_4_0-x86_64/prerequisites/Python_266/bin/python: 9: Syntax error: Unterminated quoted string

thibaut@ubuntu:~/usr/bin/SALOME-MECA-2012.1-LGPL$

 

I tried to install the latest version of Pyhton i could find with Ubuntu software center (python 3.1)

.

I also tried to run runSalomeMeca as administrator with sudo ./runSalomeMeca

.

I always get the same message.

Any Idea what to do ?

Thank you very much !

 

Thibaut

 

Re: Cannot run Salome-meca 2012.1 on Ubuntu 11.10

Posted by Claudio Julve at June 01. 2012

I know it's an old post but for another people that can come here.

use 32 or 64 bits?

if you have 32 bit install SALOME-MECA-2010.2 and do this (only for ubuntu 11.04, 11.01 and 12.04):

  1. Remove all files in etchForSalome/lib except:
    • libg2c.so.0
    • libgfortran.so.1
    • libicudata.so.36
    • libicui18n.so.36
    • libicuuc.so.36
    • libpng12.so.0
    • libreadline.so.5
    • libreadline.so.5.2
    • libg2c.so.0.0.0
  2. Remove directory etchForSalome/bin
  3. In prerequis-VXXX.sh remove the line:
    • export PATH=${DEBIANFORSALOME}/bin:${PATH}

it's works for me

Powered by Ploneboard
Document Actions