Personal tools
You are here: Home Forum Install & build Bug or trouble with universal packages 6.3.1 on Ubuntu 11.04 64 bit

Bug or trouble with universal packages 6.3.1 on Ubuntu 11.04 64 bit

Up to Install & build

Bug or trouble with universal packages 6.3.1 on Ubuntu 11.04 64 bit

Posted by Nicolas Edh at September 18. 2011

Hi, 

I'm not sure if I've encountered a bug or if it's related to the universal libraries. Anyhow I get an SIGSEGV violation every time I create a box in geometry module. Some times it will cause the entire machine to freeze sometimes only Salome.

This is what I do to repeat the SIGSEGV:

  1. Start a new study.
  2. Go to geom module
  3. Create two vertices,
    the first at (0,0,0), the second at (100,100,100). 
  4. Use the GUI button "create a box". 
  5. Create from 2 diagonal points. 
  6. Select both points in the OCC scene, (not the object browser) 
  7. After some 1-3 seconds I get a message window saying "SIGSEGV address b2". If I am fast in killing Salome the machine wont freeze.

Any help is much appreciated 

 

Best Regards

Nicolas

 

 

 

Re: Bug or trouble with universal packages 6.3.1 on Ubuntu 11.04 64 bit

Posted by DAVID Gilles at September 19. 2011

Hello Nicolas,

Can you please tell more about your environnement ?

Are you running the 32 or 64 bits package ?

Regards,

Gilles

Re: Bug or trouble with universal packages 6.3.1 on Ubuntu 11.04 64 bit

Posted by DAVID Gilles at September 19. 2011

Oops I didn't carefully read the title of the thread...

Can you please provide the list of your packages in a text file ? (dpkg -l > packages.txt)

Gilles

Re: Bug or trouble with universal packages 6.3.1 on Ubuntu 11.04 64 bit

Posted by Nicolas Edh at September 19. 2011

Hello David,

I've attached the output of dpkg. (I had to compress it)

By the way I'm sorry for my late reply, currently I can't motivate spending work hours on Salome so I do this on my spare time. Hence the of-office hours reply.

I will also try to the solution you suggested in http://www.salome-platform.org/forum/forum_9/94276987/817627186.

Best regards

Nicolas

 

Attachments

Re: Bug or trouble with universal packages 6.3.1 on Ubuntu 11.04 64 bit

Posted by Nicolas Edh at September 19. 2011

Hi,

I did the changes as you suggested in http://www.salome-platform.org/forum/forum_9/94276987/817627186 .

The "bug" is still present. However I do get some error messages when starting Salome, I don't think they are related but I'll post them any way. I've fixed the first two errors (28 and 31) by the change I mentioned in http://www.salome-platform.org/forum/forum_9/94276987/358369922

Best regards

Nicolas

ROOT_SALOME: /home/nico/OpenFOAM/Salome/Salome-V6_3_1_public_64bit/SALOME6/V6_3_1

/home/nico/OpenFOAM/Salome/Salome-V6_3_1_public_64bit/SALOME6/V6_3_1/prerequis-V6_3_1.sh: line 28: /lib/libc.so.6: No such file or directory

/home/nico/OpenFOAM/Salome/Salome-V6_3_1_public_64bit/SALOME6/V6_3_1/prerequis-V6_3_1.sh: line 31: [: -ge: unary operator expected

CHECK /home/nico

Searching for free port for the SALOME Naming Service: 2810 - Ok

runSalome running on balder

Searching for a free port for naming service: 2810 - OK

Searching Naming Service + found in 0.1 seconds 

Searching /Containers/balder/FactoryServerPy in Naming Service ++============== import HOMARD =======================

============== import SuperVisionTest =======================

 found in 1.0 seconds 

Searching /Kernel/Session in Naming Service   found in 0.0 seconds 

Start SALOME, elapsed time :   1.2 seconds

>>> Generic Warning: In /local01/salome/prerequis/src/ParaView-3101p1cm284-py266hdf5184gr2263dox173_patchxml2278qt463p1/VTK/Common/vtkObjectFactory.cxx, line 272

Old Style Factory not loaded.  Shared object has vtkLoad, but is missing vtkGetFactoryCompilerUsed and vtkGetFactoryVersion.  Recompile factory: /home/nico/OpenFOAM/Salome/Salome-V6_3_1_public_64bit/SALOME6/V6_3_1/../prerequis/../V6_3_1/PARAVIS_V6_3_1/lib/paraview/libElevationSurface.so, and use VTK_FACTORY_INTERFACE_IMPLEMENT macro.

 

Generic Warning: In /local01/salome/prerequis/src/ParaView-3101p1cm284-py266hdf5184gr2263dox173_patchxml2278qt463p1/VTK/Common/vtkObjectFactory.cxx, line 272

Old Style Factory not loaded.  Shared object has vtkLoad, but is missing vtkGetFactoryCompilerUsed and vtkGetFactoryVersion.  Recompile factory: /home/nico/OpenFOAM/Salome/Salome-V6_3_1_public_64bit/SALOME6/V6_3_1/../prerequis/../V6_3_1/PARAVIS_V6_3_1/lib/paraview/libScaleVector.so, and use VTK_FACTORY_INTERFACE_IMPLEMENT macro.

 

Generic Warning: In /local01/salome/prerequis/src/ParaView-3101p1cm284-py266hdf5184gr2263dox173_patchxml2278qt463p1/VTK/Common/vtkObjectFactory.cxx, line 272

Old Style Factory not loaded.  Shared object has vtkLoad, but is missing vtkGetFactoryCompilerUsed and vtkGetFactoryVersion.  Recompile factory: /home/nico/OpenFOAM/Salome/Salome-V6_3_1_public_64bit/SALOME6/V6_3_1/../prerequis/../V6_3_1/PARAVIS_V6_3_1/lib/paraview/libELNOFilter.so, and use VTK_FACTORY_INTERFACE_IMPLEMENT macro.

 

Generic Warning: In /local01/salome/prerequis/src/ParaView-3101p1cm284-py266hdf5184gr2263dox173_patchxml2278qt463p1/VTK/Common/vtkObjectFactory.cxx, line 272

Old Style Factory not loaded.  Shared object has vtkLoad, but is missing vtkGetFactoryCompilerUsed and vtkGetFactoryVersion.  Recompile factory: /home/nico/OpenFOAM/Salome/Salome-V6_3_1_public_64bit/SALOME6/V6_3_1/../prerequis/../V6_3_1/PARAVIS_V6_3_1/lib/paraview/libMedReaderPlugin.so, and use VTK_FACTORY_INTERFACE_IMPLEMENT macro.

 

Generic Warning: In /local01/salome/prerequis/src/ParaView-3101p1cm284-py266hdf5184gr2263dox173_patchxml2278qt463p1/VTK/Common/vtkObjectFactory.cxx, line 272

Old Style Factory not loaded.  Shared object has vtkLoad, but is missing vtkGetFactoryCompilerUsed and vtkGetFactoryVersion.  Recompile factory: /home/nico/OpenFOAM/Salome/Salome-V6_3_1_public_64bit/SALOME6/V6_3_1/../prerequis/../V6_3_1/PARAVIS_V6_3_1/lib/paraview/libParaMEDCorbaPlugin.so, and use VTK_FACTORY_INTERFACE_IMPLEMENT macro.

 

Generic Warning: In /local01/salome/prerequis/src/ParaView-3101p1cm284-py266hdf5184gr2263dox173_patchxml2278qt463p1/VTK/Common/vtkObjectFactory.cxx, line 272

Old Style Factory not loaded.  Shared object has vtkLoad, but is missing vtkGetFactoryCompilerUsed and vtkGetFactoryVersion.  Recompile factory: /home/nico/OpenFOAM/Salome/Salome-V6_3_1_public_64bit/SALOME6/V6_3_1/../prerequis/../V6_3_1/PARAVIS_V6_3_1/lib/paraview/libTableReaderPlugin.so, and use VTK_FACTORY_INTERFACE_IMPLEMENT macro.

 

Generic Warning: In /local01/salome/prerequis/src/ParaView-3101p1cm284-py266hdf5184gr2263dox173_patchxml2278qt463p1/VTK/Common/vtkObjectFactory.cxx, line 272

Old Style Factory not loaded.  Shared object has vtkLoad, but is missing vtkGetFactoryCompilerUsed and vtkGetFactoryVersion.  Recompile factory: /home/nico/OpenFOAM/Salome/Salome-V6_3_1_public_64bit/SALOME6/V6_3_1/../prerequis/../V6_3_1/PARAVIS_V6_3_1/lib/paraview/libNavigationMode.so, and use VTK_FACTORY_INTERFACE_IMPLEMENT macro.

 

th. 139858055124896 - Trace /local01/salome/V6_3_1/modules/src/GUI_V6_3_1/src/LightApp/LightApp_Application.cxx [3341] : ****************************************************************

*    Warning: library libCOMPONENT.so cannot be found

*    Module Component will not be available in GUI mode

****************************************************************

 

th. 139858055124896 - Trace /local01/salome/V6_3_1/modules/src/GUI_V6_3_1/src/LightApp/LightApp_Application.cxx [3341] : ****************************************************************

*    Warning: library libCALCULATOR.so cannot be found

*    Module Calculator will not be available in GUI mode

****************************************************************

 

th. 139858055124896 - Trace /local01/salome/V6_3_1/modules/src/GUI_V6_3_1/src/LightApp/LightApp_Application.cxx [3341] : ****************************************************************

*    Warning: library libPYCALCULATOR.so cannot be found

*    Module PyCalculator will not be available in GUI mode

****************************************************************

 

Re: Bug or trouble with universal packages 6.3.1 on Ubuntu 11.04 64 bit

Posted by DAVID Gilles at September 19. 2011

Previously Nicolas Forsberg wrote:

/home/nico/OpenFOAM/Salome/Salome-V6_3_1_public_64bit/SALOME6/V6_3_1/prerequis-V6_3_1.sh: line 28: /lib/libc.so.6: No such file or directory

/home/nico/OpenFOAM/Salome/Salome-V6_3_1_public_64bit/SALOME6/V6_3_1/prerequis-V6_3_1.sh: line 31: [: -ge: unary operator expected

 

You have an error in your prerequis-V6_3_1.sh file.

My procedure described in http://www.salome-platform.org/forum/forum_9/322811199 seems incomplete.

Please remove also all lines related to libc.so.6. You should only have:

(...)
export LANG=C

export DEBIANFORSALOME=${PREREQUIS_ROOT_DIR}/etchForSalome
export LD_LIBRARY_PATH=/lib64:${DEBIANFORSALOME}/lib:${LD_LIBRARY_PATH}
(...)

 

You can also replace 

export DEBIANFORSALOME=${PREREQUIS_ROOT_DIR}/etchForSalome

by

export DEBIANFORSALOME=${PREREQUIS_ROOT_DIR}/etchForSalome_glibc213

without having to remove the files in etchForSalome/lib, you should have the same result.

Re: Bug or trouble with universal packages 6.3.1 on Ubuntu 11.04 64 bit

Posted by Nicolas Edh at September 19. 2011

Hi,

Thank you for all the help! I still experience the same kind of crashes though.

Me prerequis looks like this now,

(...)
export LANG=C

#export DEBIANFORSALOME=${PREREQUIS_ROOT_DIR}/etchForSalome_glibc213
export DEBIANFORSALOME=${PREREQUIS_ROOT_DIR}/etchForSalome

export LD_LIBRARY_PATH=/lib64:${DEBIANFORSALOME}/lib:${LD_LIBRARY_PATH}
#------ python ------
(...)

I've tried with both etchForSalome and etchForSalome_glibc213. I still have same same errors as my previous post. ( aside from the line 28 and 31 errors).

I did try to run the universal libraries under ubuntu 10.04 64 bit on another machine and did not experiece any lockups. So I think we can exclude any bug in Salome. If the problem is incompatibility with 11.04 or if it's hardware related I can't say. I run on a Asus U36S meaning Intels sandy bridge and optimus nvida graphics card. However I've made sure that the nvida card is disabled so it shouldn't be a problem. 

If you have any more things I can try I'm willing to but some time to it.

Nicolas

Re: Bug or trouble with universal packages 6.3.1 on Ubuntu 11.04 64 bit

Posted by Nicolas Edh at October 22. 2011
The problem got solved when upgrading to Ubuntu 11.10. I guess it has something to do with the new linux kernel.
 
So, for any body else running Salome on Intel's Sandy Bridge, upgrade to 3.0.0 or newer Linux Kernel.
 
Best Regards
 
Nicolas
 

 
 
Powered by Ploneboard
Document Actions