Personal tools
You are here: Home Forum Install & build Problem compiling GUI (sip related)

Problem compiling GUI (sip related)

Up to Install & build
  • Problem compiling GUI (sip related)

    Posted by Daniel Tourde - Caelae.se at May 26. 2007
    While compiling GUI on Gentoo Linux I get the following error message:
    It seems to be sip related (I have sip 4.2.1). Any help is welcome...

           Daniel

    make[3]: Leaving directory `/var/tmp/portage/sci-misc/salome-gui-3.2.6/work/salome3.2.6_SRC/GUI_SRC_3.2.6/src/SALOME_PY'
    + for d in Qtx Style DDS QDS SUIT STD CAF CAM SUITApp LogWindow ObjBrowser Prs OBJECT GLViewer VTKViewer SVTK OCCViewer SOCC PyInterp PythonConsole Plot2d SPlot2d SUPERVGraph LightApp ResExporter RegistryDisplay TOOLSGUI Event Session SalomeApp SALOME_SWIG SALOME_PY SALOME_PYQT
    + cd SALOME_PYQT
    + make depend
    make[3]: Entering directory `/var/tmp/portage/sci-misc/salome-gui-3.2.6/work/salome3.2.6_SRC/GUI_SRC_3.2.6/src/SALOME_PYQT'
    + for d in SALOME_PYQT_GUI SalomePyQt
    + cd SALOME_PYQT_GUI
    + make depend
    make[4]: Entering directory `/var/tmp/portage/sci-misc/salome-gui-3.2.6/work/salome3.2.6_SRC/GUI_SRC_3.2.6/src/SALOME_PYQT/SALOME_PYQT_GUI'
    /usr/bin/sip -t WS_X11 -t Qt_3_3_8 -x Qt_STYLE_INTERLACE -x Qt_STYLE_WINDOWSXP -s ".cc" -c . -I /usr/share/sip/qt SALOME_PYQT_GUI.sip
    sip: /usr/share/sip/qt/versions.sip:30: Exactly one of this %Timeline must be specified with the -t flag
    make[4]: *** No rule to make target `.depend', needed by `depend'.  Stop.
    make[4]: Leaving directory `/var/tmp/portage/sci-misc/salome-gui-3.2.6/work/salome3.2.6_SRC/GUI_SRC_3.2.6/src/SALOME_PYQT/SALOME_PYQT_GUI'
    + exit 1
    make[3]: *** [depend] Error 1
    make[3]: Leaving directory `/var/tmp/portage/sci-misc/salome-gui-3.2.6/work/salome3.2.6_SRC/GUI_SRC_3.2.6/src/SALOME_PYQT'
    + exit 1
    make[2]: *** [depend] Error 1
    make[2]: Leaving directory `/var/tmp/portage/sci-misc/salome-gui-3.2.6/work/salome3.2.6_SRC/GUI_SRC_3.2.6/src'
    + exit 1
    make[1]: *** [depend] Error 1
    make[1]: Leaving directory `/var/tmp/portage/sci-misc/salome-gui-3.2.6/work/salome3.2.6_SRC/GUI_SRC_3.2.6'
    make: *** [all] Error 2
    make: INTERNAL: Exiting with 2 jobserver tokens available; should be 3!
    • Re: Problem compiling GUI (sip related)

      Posted by Daniel Tourde - Caelae.se at May 26. 2007
      The solution mentionned in thread 1212 did the trick... I have qt 3.3.8 and it was not listed in the Makefile.in files.
Powered by Ploneboard
Document Actions