Personal tools
You are here: Home Forum Install & build Error libSalomeApp.so

Error libSalomeApp.so

Up to Install & build
  • Error libSalomeApp.so

    Posted by schubert at June 21. 2007
    Hi all,

    I'm getting a error when starting Salome 3.2.6 on Kubuntu 7.04.

    Can not laod application library "libSalomeApp.so": /home/arthur/OpenFOAM/linux/gcc-4.1.2/lib/libgcc_s.so.1: version 'GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6

    I've installed from InstallWizard_3.2.6_DebianSarge and with this howoto:

    http://ubuntuforums.org/showthread.php?p=2798669

    any help?

    thx

    arthur
    • Re: Error libSalomeApp.so

      Posted by Kwun Ho Ngan at June 21. 2007
      Try to see if you have installed gcc from sympatic. I think you are missing the C compiler to start things off.
      • Re: Error libSalomeApp.so

        Posted by schubert at June 22. 2007
        Kwun Ho Ngan wrote:
        Try to see if you have installed gcc from sympatic. I think you are missing the C compiler to start things off.


        I already checked it.

        I have :

        gcc
        gcc-3.3-base
        gcc-3.4
        gcc-3.4-base
        gcc-4.1
        gcc-4.1-base
        libgcc1

        installed. I already try to install gcc 4.2.0 too but I don't finde any packages for ubuntu 7.04.
        • Re: Error libSalomeApp.so

          Posted by Kwun Ho Ngan at June 22. 2007
          What is your version of libstdc++? I have 4.1.2-0ubuntu4 installed. I am using ubuntu 7.0.4 though.
          • Re: Error libSalomeApp.so

            Posted by schubert at June 22. 2007
            Kwun Ho Ngan wrote:
            What is your version of libstdc++? I have 4.1.2-0ubuntu4 installed. I am using ubuntu 7.0.4 though.


            I have libstdc++ 5 & libstdc++ 6 installed
            The first one required gcc3.3 and the second gcc 4.1.2-0ubuntu4.
            My gcc version is gcc3.3.6-15ubuntu1 and gcc4.1.2-0ubuntu4.




            • Re: Error libSalomeApp.so

              Posted by Kwun Ho Ngan at June 22. 2007
              That's very strange 'cause I have similar setting as you do and I don't have any error when installed as the instruction that you follow. gcc_4.2.0 is the latest which is only out in May.

              Just by any luck, did you recently install anything or compile from source anything that has a link with the latest gcc?

              My apology if I have guided you around the bush but I am not an expert. I also learn to install and use Salome by trial and error.


              • Re: Error libSalomeApp.so

                Posted by schubert at July 05. 2007
                Kwun Ho Ngan wrote:
                That's very strange 'cause I have similar setting as you do and I don't have any error when installed as the instruction that you follow. gcc_4.2.0 is the latest which is only out in May.

                Just by any luck, did you recently install anything or compile from source anything that has a link with the latest gcc?

                My apology if I have guided you around the bush but I am not an expert. I also learn to install and use Salome by trial and error.



                Accidently I found the solution of my problem. In addiction to salome I've installed OpenFOAM too. I did using this http://ubuntuforums.org/showthread.php?t=156298 howto. The problem was stetting of enviromet variables. After removing this modification of the bash I can start salome without any problems.
Powered by Ploneboard
Document Actions