Personal tools
You are here: Home Forum Install & build works - Salome 3.2.6 on Ubuntu 64 bit Gutsy amd64

works - Salome 3.2.6 on Ubuntu 64 bit Gutsy amd64

Up to Install & build
  • works - Salome 3.2.6 on Ubuntu 64 bit Gutsy amd64

    Posted by Thomas Ward at October 25. 2007
    I have just installed Salome 3.2.6 on Ubuntu, seems to work well

    steps I did in no particular order

    1.
    read through the requirements for Salome Mandriva 2006 64 bit
    and install the dev versions of everythin on the list - not sure if this was neccessary but I thought it wouldn't harm anything

    2. install google earth, install all 32bit libraries from defaults locations and for 32bit firefox/ acrobat

    3.
    link /usr/lib32/libpng12.so.something to /usr/lib32/libpng

    4.
    copy 64bit libgfortran.so.0 from an FC4 rpm  - googled for "libgfortran.so.0 FC4"
    did this via rpm2cpio and mc
    ftp://ftp.rpmfind.net/linux/fedora/core/updates/4/x86_64/libgfortran-4.0.2-8.fc4.x86_64.rpm


    5.
    ran the install tool and installed all from binaries except netgen which I installed from source (I wanted to make sure this was 64bit becase I was running out of memory on 32bit2)
    Ignored warnings about the wrong gcc verision


    it works so far but I have only loaded in a previos model and meshed it, seems OK

    thank you to the SALOME team for makeing SALOME available,

    Tom Ward






    • Re: works - Salome 3.2.6 on Ubuntu 64 bit Gutsy amd64

      Posted by aali978 at October 29. 2007
      What I have not fully understood what you installed google earth? ? ? What realation with? ?
      I had the problem that some modules do not work  (libgfortrant.so.0 does not exist), I have centOS 5 (64bits), and that's why I believe that the key step  was really No. 4
      • Re: works - Salome 3.2.6 on Ubuntu 64 bit Gutsy amd64

        Posted by Dario77 at November 20. 2007
        I've installed salome 64 on ubuntu 7.04 64 bit, on Centos 5 64 bit and on Debian 4.0r1 64 bit.

        On centos 5 I've installed salome with ./runInstall and installed netgen source

        On Debian and ubuntu I used ./runIstall -b and I've modificated the config.xml as follow


                   version="4.5"
                   description="Quadrangle meshing algorithmic tool"
                   install="install sources"
               supported="install sources,install binaries"
               disable="false"
               dependancies="gcc,OpenCascade"
               installdiskspace="7533"
               temporarydiskspace="11936"
               script="netgen-4.5.sh"/>

        I've installed libgfortran.so.0.0.0 from a Fc4 rpm and linked as libgfortran.so.0 in usr/lib and it works for all sistems I've tested.

        On ubuntu and on debian I've installed libpng.
        • Re: works - Salome 3.2.6 on Ubuntu 64 bit Gutsy amd64

          Posted by Seth Jackson at January 17. 2008
          hi,

          how did you compile OpenCascade for ubuntu 64bit?  do you have a copy of the libs you could send me?

          -Seth
          • Re: works - Salome 3.2.6 on Ubuntu 64 bit Gutsy amd64

            Posted by Adam Powell at January 18. 2008
            Seth Jackson wrote:
            hi,

            how did you compile OpenCascade for ubuntu 64bit?  do you have a copy of the libs you could send me?

            -Seth



            I made an OpenCascade Debian package which should install in Ubuntu, see http://lyre.mit.edu/~powell/opencascade/

            I am completing a Salomé package as well, stay tuned...
Powered by Ploneboard
Document Actions