Personal tools
You are here: Home Forum Install & build problems running samples

problems running samples

Up to Install & build
  • problems running samples

    Posted by Manav Bhatia at March 09. 2008
    Hi, I am new to Salome. I have installed the binaries from both Debian and Mandriva builds on my Suse machine. I am able to use the GUI, and have played with the geometry package so far, which seems to be running fine. However, when I run the example problems (available from the user section webpage), the python scripts exit with the same error. For example, running the mangetron.py gives manav@ericjohnson:~/salome_examples> python magnetron.py createNewStudy Traceback (most recent call last): File "magnetron.py", line 9, in ? import smesh, math File "/l/manav/salome/Mandriva/SMESH_3.2.6/bin/salome/smesh.py", line 30, in ? import geompy File "/l/manav/salome/Mandriva/GEOM_3.2.6/bin/salome/geompy.py", line 30, in ? salome.salome_init() File "/l/manav/salome/Mandriva/KERNEL_3.2.6/lib/python2.3/site-packages/salome/salome.py", line 64, in salome_init myStudyManager, myStudyId, myStudy, myStudyName =salome_study_init(theStudyId) File "/l/manav/salome/Mandriva/KERNEL_3.2.6/lib/python2.3/site-packages/salome/salome_study.py", line 317, in salome_study_init myStudyId = getActiveStudy(theStudyId) File "/l/manav/salome/Mandriva/KERNEL_3.2.6/lib/python2.3/site-packages/salome/salome_study.py", line 261, in getActiveStudy salome_study_ID = createNewStudy() File "/l/manav/salome/Mandriva/KERNEL_3.2.6/lib/python2.3/site-packages/salome/salome_study.py", line 272, in createNewStudy listOfOpenStudies = myStudyManager.GetOpenStudies() File "/l/manav/salome/Mandriva/KERNEL_3.2.6/lib/python2.3/site-packages/salome/SALOMEDS_idl.py", line 793, in GetOpenStudies return _omnipy.invoke(self, "GetOpenStudies", _0_SALOMEDS.StudyManager._d_GetOpenStudies, args) omniORB.CORBA.TRANSIENT: Minor: TRANSIENT_ConnectFailed, COMPLETED_NO. I get the same behavior from both the Debian and the Mandriva builds. I would appreciate any help on this issue. The contents of my omniORB.cfg file are InitRef = NameService=corbaname::ericjohnson:2810 I do not have root access to this machine. Any insight will be appreciated. I will be happy to provide more information on this matter that might help in resolving the issue. Regards, Manav
Powered by Ploneboard
Document Actions