Personal tools
You are here: Home Forum Install & build Salome 3.2.9 in Ubuntu 8.04 64bit

Salome 3.2.9 in Ubuntu 8.04 64bit

Up to Install & build
  • Salome 3.2.9 in Ubuntu 8.04 64bit

    Posted by JMB at August 31. 2008
    I have a problem running Salome 3.2.9 in my Ubuntu 8.04 Hardy 64bit PC. I installed using the following steps:

    [code]
        sudo mv /home/user/Download/SALOME-MECA-2008.1-GPL.tgz /opt
        cd /opt
        sudo tar -zxf SALOME-MECA-2008.1-GPL.tgz
        cd /opt/SALOME-MECA-2008.1-GPL/postinstall/
        sudo python ./postinstall.py
    [/code]

    All the modules are installed with green [OK]s

    When I run using:

    [code]
        /opt/SALOME-MECA-2008.1-GPL/runSalomeMeca
    [/code]

    I get:

    [code]
    CHECK /home/user
    Searching for free port for the SALOME Naming Service: 2810 - Ok
    Configure parser: Warning : could not find configuration file /opt/SALOME-MECA-2008.1-GPL/SALOME/SALOME3/V3_2_9NoDebug/GUI_V3_2_9NoDebug/share/salome/resources/SalomeApp.xml
    Configure parser: Warning : could not find user configuration file
    Searching for a free port for naming service: 2810 - OK
    Lancement du Naming Service runNS.sh > /tmp/logs/user/salomeNS.log 2>&1
    Searching Naming Service + found in 0.1 seconds
    Searching /Containers/ubuntu16/FactoryServerPy in Naming Service ++ found in 1.0 seconds
    Searching /Kernel/Session in Naming Service ++ found in 1.0 seconds
    Start SALOME, elapsed time :   2.2 seconds
    additional external python interpreters:  0
    >>>

    [/code]

    I can see the "Splash" screen and all the Containers being loaded as the progress bar fills up from left to right.  Then nothing.  No Salome!  I stare at the screen and it stares back at me.  I have installed Salome 3.2.9 on several 32bit Ubuntu PCs and they work fine.   The /tmp/logs/user/salomeNS.log is not anything I can understand.  Is the absence of the "/opt/SALOME-MECA-2008.1-GPL/SALOME/SALOME3/V3_2_9NoDebug/GUI_V3_2_9NoDebug/share/salome/resources/SalomeApp.xml" file the problem?  I have checked all other 32bit PCs and they too lack this file but Salome 3.2.9 works ok on them.  Any ideas?  thank you for any help you or others can offer.

    Regards,
    JMB
    • Re: Salome 3.2.9 in Ubuntu 8.04 64bit

      Posted by JMB at September 26. 2008
      Hello,

      1. Installing ia32-libs solved the "dirname" problem.
      2. Installing the latest nVidia drivers using EnvyNG solved the Salome graphics problem.

      Thanks to the administrator on CAElinux forum!

      Regards,
      JMB
Powered by Ploneboard
Document Actions