Personal tools
You are here: Home Forum Install & build Errors in GEOM at NMT* packages

Errors in GEOM at NMT* packages

Up to Install & build
  • Errors in GEOM at NMT* packages

    Posted by Fotis Sioutis at January 27. 2009
    In NMTTools\NMTTools_PCurveMaker.cpp line 97 InterfPool() method from NMTTools_PaveFiller is called but it is not declared and implemented.
    In NMTTools\NMTTools_DSFiller.cpp line 166 constructor of NMTTools_PaveFiller with parameter a BOPTools_InterferencePool is called but it is not declared and implemented.

    Also compiling the NMTAlgo package revealed more errors that have to do with NMTTools_PaveFiller class.

    Searching a bit i found that the above methods existed in 3.2.6 but not any more in 4.1.4.

    Any thoughts on the above would be appreciated !!

    Fotis

    • Re: Errors in GEOM at NMT* packages

      Posted by Vadim SANDLER at January 28. 2009
      Hello Fotis,

      If you look into Makefile.am you'll find that the file NMTTools_PCurveMaker.cpp is not included into the build procedure. It is obsolete.

      Regards,
      Vadim.
      • Re: Errors in GEOM at NMT* packages

        Posted by Fotis Sioutis at January 28. 2009
        Thanks a lot Vadim !

        Also NMTTools_DSFiller is deprecated, and the package NMTAlgo is out of use.Updating my projects accordingly solved all errors.

        Have a nice day !

        Fotis
Powered by Ploneboard
Document Actions