Personal tools
You are here: Home Forum Install & build pb with environment settings on ubuntu

pb with environment settings on ubuntu

Up to Install & build
  • pb with environment settings on ubuntu

    Posted by guillaume niel at January 28. 2006
    Hello,
    I'm trying to install salome 2.2.8 with ubuntu. The first step with the installation wizard  seems to be ok : every package and binary was installed without any error message. So now I want to set the environment but when I type "source salome.sh" in the terminal, the following message appears :

    bash: printenv: no such file or directory
    bash: awk: no such file or directory

    What am I supposed to do now ?

    Thanks for your help

    Guillaume
    • Re: pb with environment settings on ubuntu

      Posted by guillaume niel at January 28. 2006
      Actually, the entire message is :

      awk: program limit exceeded: sprintf buffer size=1020
              FILENAME="-" FNR=1 NR=1
      awk: program limit exceeded: sprintf buffer size=1020
              FILENAME="-" FNR=1 NR=1

      and then a serie of :

      bash: printenv: no such file or directory
      bash: awk: no such file or directory

      What is the problem ?

      Guillaume
      • Re: pb with environment settings on ubuntu

        Posted by guillaume niel at January 28. 2006
        One more thing :
        when I try "source salome.csh", here is the message :

        bash: alias: cleandup: not found
        bash: alias: `echo \!:1 \!:2 | awk -v dir': invalid alias name
        bash: alias: setenva: not found
        bash: alias: `set a': invalid alias name
        bash: alias: setenvp: not found
        bash: alias: `set a': invalid alias name
        bash: salome.csh: line 379: syntax error: unexpected end of file

        Help!...

        Guillaume
        • Re: pb with environment settings on ubuntu

          Posted by Bernt-Ola Sandström at January 28. 2006
          Hi!

          I had the same problem on Debian but I found a solution for it.

          In the file salome.sh change the second source row according to the following

          out_var=`echo $1 $2 | awk -W sprintf=3060 -v dir=$3 '{ \ na = split($2,a,":";); \

          Regards!

          Bernt-Ola Sandström
          • Re: pb with environment settings on ubuntu

            Posted by Bernt-Ola Sandström at January 28. 2006
            Hi!

            Sorry about the extra formatting information resulting from copy/paste.

            The source line that needs to be changed is of course only the color highlited
            line.

            Regards!

            Bernt-Ola Sandström
            • Re: pb with environment settings on ubuntu

              Posted by guillaume niel at January 29. 2006
              Thanks for this information !
              I managed to set the environment with this.
              But now, I am trying to launch salome (runsalome), and here is the message :

               Searching for a free port for naming service: 2810 - Ok
              Traceback (most recent call last):
                File "/salome/KERNEL_2.2.8/bin/salome/runSalome.py", line 761, in ?
                  clt,args = main()
                File "/salome/KERNEL_2.2.8/bin/salome/runSalome.py", line 751, in main
                  args, modules_list, modules_root_dir = get_config()
                File "/salome/KERNEL_2.2.8/bin/salome/runSalome.py", line 45, in get_config
                  import launchConfigureParser
                File "/salome/KERNEL_2.2.8/bin/salome/launchConfigureParser.py", line 98, in ?    import Utils_Identity
                File "/salome/KERNEL_2.2.8/bin/salome/Utils_Identity.py", line 33, in ?
                  import socket
                File "/salome/Python-2.2.1/lib/python2.2/socket.py", line 41, in ?
                  from _socket import *
              ImportError: libssl.so.2: cannot open shared object file: No such file or directory


              I understand that I need libssl.so.2 , but I don't know how to get it (doesn't appear in Synaptic). How can I do ?

              Guillaume
              • Re: pb with environment settings on ubuntu

                Posted by guillaume niel at January 29. 2006
                Hi,
                With another post, I managed to fix the problem with different library files which were apparently missing ( links to create in the Kernel/lib directory).
                I managed to launch salome once (victory !!) but when I tried again to launch it, the following message appeared :

                Searching for a free port for naming service: 2810 2811 - Ok
                python: can't open file '/bin/salome/runSalome.py': [Errno 2] No such file or directory

                But the file runSalome.py is still there !!
                I think that the link to  the runSalome.py file in the runSalome file is not OK, but what have I to do to repair that ?

                Guillaume
                • Re: pb with environment settings on ubuntu

                  Posted by Bernt-Ola Sandström at January 30. 2006
                  Hi! I used the RedHat 8.0 installation configuration file for my Debian and that seems to work OK. I had some similar problem with the missing file when I used the Mandrake config file. Bernt-Ola
                  • Re: pb with environment settings on ubuntu

                    Posted by guillaume niel at January 31. 2006
                    Hi, I found that by doing a "source salome.sh" again, it works. So the command "source" is not permanent. Each time I want to launch salome, I have to type "source salome.sh" first.
                    I can't explain that, but I'll try to use the other configuration file to install salome to see if it fixes the problem.
                    Thanks for your help

                    Guillaume
                    • Re: pb with environment settings on ubuntu

                      Posted by Serge Montagnac at January 31. 2006
                      These problems come from the fact that salome is opening new shells during the launch phase of applications ....
                      resetting some variables salome.sh had setup precedently

                      I had a problem like that : 2 different QT versions(3.1 and 3.34) and 2 versions of Python(2.2 and 2.3)  OK ...
                      my ($HOME)/.bashrc is declaring variables and $PATH for qt3.34 and python2.3.

                      As you did, I ran salome.sh and then bin/runSalome ----> crash (reason= bad versions of qt and python... right !)

                      I created a modified ($HOME)/.bashrc_salome declaring QT3.1 and python2.2. and sourced it.

                      I ran salome.sh again, and then bin/runSalome --->salome starts, but as I open the Geometry new context --->crash (reason=salome opens
                      a new shell and source the initial .bashrc which is wrong !

                      So I have to maintain 2 .bashrc .... .bashrc_normal and .bashrc_salome and before launching salome I copy .bashrc_salome on .bashrc

                      It's a not too academic method, but It works !
                      • Re: pb with environment settings on ubuntu

                        Posted by Serge Montagnac at January 31. 2006
                        Just in case people wants to install on Mandrake9.1 or 10 ... and have a crash at new Gometry launching  ....

                        Si ces lignes ne sont pas présentes dans le fichier .bashrc, vous aurez toujours des problèmes
                        après le lancement, dans les applications.
                        Il serait possible de retrouver les failles des variables d'environnement de salomé, mais cela ne vaux pas la peine.
                        Trop complexe.

                        #Pour mon qt-3.0.5 salome
                        QTDIR=/home/salome/qt-x11-free-3.0.5/
                        PATH=$PATH:$QTDIR/bin
                        MANPATH=$QTDIR/doc/html:$MANPATH
                        LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
                        export QTDIR PATH MANPATH LD_LIBRARY_PATH
                        # Pour mon Python-2.2.2
                        export PYTHONHOME=/usr
                        export PYTHON_INCLUDE=$PYTHONHOME/include/python2.2
                        export PYTHONPATH=$PYTHONHOME/lib/python2.2:$PYTHONPATH
                        export PATH=$PYTHONHOME/bin:$PATH
                        export LD_LIBRARY_PATH=$PYTHONHOME/lib/python2.2:$LD_LIBRARY_PATH


                        Pour ne pas faire de bêtises :
                        cp  .bashrc   .bashrc_original
                        cp  .bashrc   .bashrc_salome
                         
                        ensuite, vous éditez le .bashrc_salome et ajouter (copie/coller) simplement le bloc ci-dessus ...
                        (verifiez et adaptez soigneusement à votre installation, seulement les chemins  en rouge ci-dessous !! ...)
                        (j'espère que votre mailer accepte l'html :))

                        Il suffit de faire un
                        cp .bashrc_salome  .bashrc
                        source .bashrc
                        pour faire du salomé et conserver les variables correctes car salomé tombera toujours sur le bon .bashrc ....
                        quand vous voulez revenir a la config de base !  :

                        cp .bashrc_original  .bashrc
                        source .bashrc

                        Fin !!!



                        #Pour mon qt-3.0.5 salome
                        QTDIR=/home/salome/qt-x11-free-3.0.5/
                        PATH=$PATH:$QTDIR/bin
                        MANPATH=$QTDIR/doc/html:$MANPATH
                        LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
                        export QTDIR PATH MANPATH LD_LIBRARY_PATH
                        # Pour mon Python-2.2.2
                        export PYTHONHOME=/usr
                        export PYTHON_INCLUDE=$PYTHONHOME/include/python2.2
                        export PYTHONPATH=$PYTHONHOME/lib/python2.2:$PYTHONPATH
                        export PATH=$PYTHONHOME/bin:$PATH
                        export LD_LIBRARY_PATH=$PYTHONHOME/lib/python2.2:$LD_LIBRARY_PATH






Powered by Ploneboard
Document Actions