Personal tools
You are here: Home Forum Install & build runSalome and libssl.so.2 library

runSalome and libssl.so.2 library

Up to Install & build
  • runSalome and libssl.so.2 library

    Posted by Isabel at March 06. 2006
    Hi to everybody!!

    I have a problem when I try to run Salome.
    First, I run the salome.sh script and later I run Salome with runSalome command. I get the following error message:

    Searching for a free port for naming service: 2810 - Ok
    Traceback (most recent call last):
      File "/home/misabel/salome/KERNEL_2.2.8/bin/salome/runSalome.py", line 761, in ?
        clt,args = main()
      File "/home/misabel/salome/KERNEL_2.2.8/bin/salome/runSalome.py", line 751, in main
        args, modules_list, modules_root_dir = get_config()
      File "/home/misabel/salome/KERNEL_2.2.8/bin/salome/runSalome.py", line 45, in get_config
        import launchConfigureParser
      File "/home/misabel/salome/KERNEL_2.2.8/bin/salome/launchConfigureParser.py", line 98, in ?
        import Utils_Identity
      File "/home/misabel/salome/KERNEL_2.2.8/bin/salome/Utils_Identity.py", line 33, in ?
        import socket
      File "/home/misabel/salome/Python-2.2.1/lib/python2.2/socket.py", line 41, in ?
        from _socket import *
    ImportError: libssl.so.2: cannot open shared object file: No such file or directory

    I have looked for 'libssl.so.2' in /usr/lib directory and it is there, so I don't know what could be the problem.
    I would be really grateful for receiving some advice.

    Thanks!
    Isa
    • Re: runSalome and libssl.so.2 library

      Posted by Isabel at March 06. 2006
      Hi again!
      I have solved the previous problem with library libssl.so.2, it was my "ld.so.conf" file, Salome was looking for libraries in the wrong paths.

      Now, when I type "runSalome -g -k", the image of Salome appears but I get lots of error messages of the type:

      +th. 1564330928 - Trace /vsr/salome_2.2.8/KERNEL_SRC_2.2.8/src/NamingService/SALOME_NamingService.cxx [337] : Resolve() : Containers (dir) not found and the launch doesn't happen.

      any advice?
      Again, thank-you very much
      Isa
      • Re: runSalome and libssl.so.2 library

        Posted by Jan Peters at May 23. 2006
        Hi,

        I've got the same problem you mentioned in your first post. Now could you possibly explain to a newby like me how exactly you solved that?
        Which paths do I have to change and were do I have to change them?

        Greetings
        Jan
Powered by Ploneboard
Document Actions