Personal tools
You are here: Home Forum Use Shaper module: can't add sketch entities

Shaper module: can't add sketch entities

Up to Use

Shaper module: can't add sketch entities

Posted by Nejc Jurkovic at June 14. 2019

Hello.

 

I'm trying out the Shaper module on a Windows install and I can't add any entities. All the entities are availabla (point, line, circle, ...) but when I click to add an entity, nothing happens.

I do follow the official tutorial. Is there something I missed in settings or during installation or is there something wrong and I am the only one with this issue?

Thanks.

Re: Shaper module: can't add sketch entities

Posted by Christophe Bourcier at June 18. 2019

Hi,

Maybe you have missed a step.

In sketch creation mode, you have to select a plane to be able to create entities.

To sum up:

- create a part

- create a sketch

- select a plane (either in the 3D view or in the tree under Construction)

- create entities in the sketch (line, arcs...)

- add constraints

Christophe

Attachments

Re: Shaper module: can't add sketch entities

Posted by Nejc Jurkovic at June 19. 2019

Hello,

yes, I do everything as you stated. When adding sketch entities even cursor changes but no entities are visible or added.

Re: Shaper module: can't add sketch entities

Posted by Christophe Bourcier at June 19. 2019

Strange, I have checked again in Windows 7 and Windows 10 and it works fine.

Can you share some information on your Operating System and your graphic card?

Christophe

Re: Shaper module: can't add sketch entities

Posted by Nejc Jurkovic at June 19. 2019
I have Win 10 Pro, build 1809 25.3.2019, build 17763.557.
Graphics card is Nvidia GeForce GTX 1050, driver build 23.21.13.8813, 27. 10. 2017. The driver was installed by windows and is, as it seems, the latest. The official Nvidia website has offers drivers from 2016.
Could I try disabling it or maybe try with integrated graphics? (that is, if you suspect graphics are the culprit).
 
Thanks for your effort.

Re: Shaper module: can't add sketch entities

Posted by Christophe Bourcier at June 19. 2019

Your Windows version is more up-to-date than mine. A colleague had an error at Salome startup after a Windows update, but it has been resolved by another Windows update... I don't know if the minor version of Windows is the problem...

Your Nvidia graphic card should work fine. There are some troubles with very old nvidia card or intel chipset.

Another idea: maybe it is because you have changed the interaction mode of the view to be able to manipulate it without pressing the control key. In this mode, you can't create elements in the sketcher, you have to switch to the standard mode.

Re: Shaper module: can't add sketch entities

Posted by Nejc Jurkovic at June 20. 2019

Well yes, now when I switched to standard mode, everything works fine. I would never have guessed by myself.

Thanks for your help.

However, I do feel this should somehow  be avoided. Probably I'm not the only one that uses the keyboard-free style navigation?

Powered by Ploneboard
Document Actions