Personal tools
You are here: Home Forum Extension of the platform Error Using YACSGEN

Error Using YACSGEN

Up to Extension of the platform

Error Using YACSGEN

Posted by Brigity Volund at November 18. 2021

Hi All, ran into another interesting issue with YACSGEN. I ran the following in terminal that I can not sort out:

source env_launch.sh

python mymodule.py

 

But got the following error:

CMake Error at /home/dan/programs/salome-9.7.0/BINARIES-UB20.04/KERNEL/salome_adm/cmake_files/SalomeKERNELConfig.cmake:46 (message):

  File or directory

  /volatile/salome/jenkins/workspace/Salome_master_native_UB20/SALOME-9.7.0-native-UB20.04/INSTALL/omniORB

  referenced by variable OMNIORB_ROOT_DIR_EXP does not exist !

Call Stack (most recent call first):

  /home/dan/programs/salome-9.7.0/BINARIES-UB20.04/KERNEL/salome_adm/cmake_files/SalomeKERNELConfig.cmake:111 (SET_AND_CHECK)

  /home/dan/programs/salome-9.7.0/BINARIES-UB20.04/CONFIGURATION/cmake/SalomeMacros.cmake:433 (FIND_PACKAGE)

  /home/dan/programs/salome-9.7.0/BINARIES-UB20.04/CONFIGURATION/cmake/FindSalomeKERNEL.cmake:42 (SALOME_FIND_PACKAGE)

  CMakeLists.txt:36 (FIND_PACKAGE)

-- Configuring incomplete, errors occurred!

See also "/home/dan/programs/salome-9.7.0/sandbox/mymodule_build/CMakeFiles/CMakeOutput.log".

Traceback (most recent call last):

  File "mymodule.py", line 24, in <module>

    g.configure()

  File "/home/dan/programs/salome-9.7.0/BINARIES-UB20.04/YACSGEN/lib/python3.8/site-packages/module_generator/gener.py", line 845, in configure

    raise Invalid("configure has ended in error")

module_generator.gener.Invalid: configure has ended in error

 

mymodule.py contains the following simple code:

 

from module_generator import Generator,Module

from module_generator import PYComponent,CPPComponent,Service,F77Component

 

context={"update":1,

         "prerequisites":"/home/brigity/programs/salome-9.7.0",

         "kernel":"/home/brigity/programs/salome-9.7.0/BINARIES-UB20.04"

        }

pyc1=PYComponent("mycompo",

                 services=[

                           Service("myservice",

                                   inport=[("inputport","double"),],

                                   outport=[("outputport","double")],

                                   defs="import sys",

                                   body="      outputport=2*inputport;",

                                  ),

                          ]

                )

m=Module("mymodule",components=[pyc1],prefix="Install")

g=Generator(m,context)

g.generate()

g.configure()

g.make()

g.install()

g.make_appli("appli",restrict=["KERNEL","GUI","YACS"])

Please advise. Apologies in advance if this is a silly question...

Re: Error Using YACSGEN

Posted by Brigity Volund at November 18. 2021

Ubuntu 20.04. 

Sorted this one out. After replacing all instances of "/volatile/salome/jenkins/workspace/Salome_master_native_UB20/SALOME-9.7.0-native-UB20.04/INSTALL/omniORB" found in File, "SalomeKERNELConfig.cmake" located in /salome-9.7.0/BINARIES-UB20.04/KERNEL/salome_adm/cmake_files" along with all the other paths in that file that started like, "/volatile/salome/jenkins/..." with the actual paths on my computer to the omniORB folder, the PRODUCTS folder, and the LIBBATCH folder (all are inside BINARIES-UB20.04), the problem was fixed. 

Powered by Ploneboard
Document Actions