Personal tools
You are here: Home Forum Other... (new forum, problems, etc.) MEDCoupling: problem with boundary of PENTA15 cells

MEDCoupling: problem with boundary of PENTA15 cells

Up to Other... (new forum, problems, etc.)

MEDCoupling: problem with boundary of PENTA15 cells

Posted by Roberto Da Vià at May 11. 2021

Re: MEDCoupling: problem with boundary of PENTA15 cells

Posted by Roberto Da Vià at May 11. 2021

Hi everybody,

I'm sorry for the empty text box but I had some problems with the browser window.

The issue I found is related to the calculation of the boundary sides of PENTA15 cells. I'm doing some tests on a mesh containing just one PENTA15 cell and the mesh has been computed using SALOME.

From a script I'm using the MEDCoupling::MEDCouplingUMesh::buildBoundaryMesh() function to build the boundary faces of the PENTA15 cells. Everything works fine, except for one of the QUAD8 faces, which has a wrong connectivity, as you can see in the attached figure.

I'm using the latest (9.6.0) of both salome and MEDCoupling (that I compiled separately).

Thank you for the support,

Roberto

Attachments

Re: MEDCoupling: problem with boundary of PENTA15 cells

Posted by Nabil Ghodbane at May 12. 2021

Hi, can you possibly share your script as well as the mesh such that we can raise the issue to the MEDCOUPLING developers ?

Re: MEDCoupling: problem with boundary of PENTA15 cells

Posted by Roberto Da Vià at May 12. 2021

Dear Nabil,

you are right. In the attached archive you can find:

- penta15.med  -> the volume mesh containing only one PENTA15 cell

- bound_penta15.med  ->  the boundary mesh computed on the PENTA15 cell

- penta15_boundary.py  -> the python script used to compute the boundary mesh

Thank you,

Roberto

 

Previously Nabil Ghodbane wrote:

Hi, can you possibly share your script as well as the mesh such that we can raise the issue to the MEDCOUPLING developers ?

 

Attachments

Re: MEDCoupling: problem with boundary of PENTA15 cells

Posted by Roberto Da Vià at May 31. 2021

Hello everybody,

I found the bug that caused the construction of the wrong boundary side for PENTA15 cell.

The bug is located in the source file:

INTERP_KERNEL/
      CellModel.cxx
             CellModel::CellModel(NormalizedCellType type):_type(type)
                    case NORM_PENTA15:

The bug is in the connectivity of the last son (_sons_con[4]), that should be:

    _sons_con[4][0]=2;
    _sons_con[4][1]=5;  // in the original file it was 4
    _sons_con[4][2]=3;  // in the original file it was 5
    _sons_con[4][3]=0;
    _sons_con[4][4]=14;
    _sons_con[4][5]=11;
    _sons_con[4][6]=12;
    _sons_con[4][7]=8; 

I tested the new connectivity and it works fine. I hope to see these changes in the next versions of MEDCoupling :)

Roberto

Re: MEDCoupling: problem with boundary of PENTA15 cells

Posted by Anthony GEAY at May 31. 2021

Hello Roberto,

You perfectly right this is clearly a bug. Sorry about that.

Thank you for you proposed patch. I've integrated it into master branch of medcoupling with a non regression test associated.

This debug will be available in the future V9_8_0 at the end of the year.

Regards,

Quick reply
URLs will be automatically hyperlinked. Basic HTML tags are OK.
Powered by Ploneboard
History
Activate by Roberto Da Vià on May 11, 2021 11:41 AM
Document Actions