Personal tools
You are here: Home Forum Install & build I can not install Salome 8.2.0 in Ubuntu 16.10

I can not install Salome 8.2.0 in Ubuntu 16.10

Up to Install & build

I can not install Salome 8.2.0 in Ubuntu 16.10

Posted by LUIGGI CARDENAS ACUÑA at April 22. 2017

Hello¡

Dear community

I am new in this platform, I hope you can help me.

I have downloaded the universal binary file for Ubuntu and the official binary  for Ubuntu 16.04 64 bits according to the web page this is the last version, but my Ubuntu is 16.10.

1. After decompressing the .tgz and running ./salome, i got the next error:

unSalome running on luiggi-N551JX
Searching for a free port for naming service: 2811 - OK
cp: target '/tmp/logs/luiggi/env_2811/Plugin' is not a directory
cp: target '/tmp/logs/luiggi/env_2811/GEOMDS_Resources' is not a directory
cp: target '/tmp/logs/luiggi/env_2811/ShHealing' is not a directory
Searching Naming Service + found in 0.1 seconds
SALOME_Session_Server: error while loading shared libraries: libicui18n.so.55: cannot open shared object file: No such file or directory
Traceback (most recent call last):
  File "/home/luiggi/Documents/INVESTIGACION/MODELACION SALAVERRY - TELEMAC/SALOME/SALOME-8.2.0-UB16.04/BINARIES-UB16.04/KERNEL/bin/salome/runSalome.py", line 622, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)
  File "/home/luiggi/Documents/INVESTIGACION/MODELACION SALAVERRY - TELEMAC/SALOME/SALOME-8.2.0-UB16.04/BINARIES-UB16.04/KERNEL/bin/salome/runSalome.py", line 567, in startSalome
    session=clt.waitNSPID("/Kernel/Session",mySessionServ.PID,SALOME.Session)
  File "/home/luiggi/Documents/INVESTIGACION/MODELACION SALAVERRY - TELEMAC/SALOME/SALOME-8.2.0-UB16.04/BINARIES-UB16.04/KERNEL/bin/salome/orbmodule.py", line 174, in waitNSPID
    raise RuntimeError, "Process %d for %s not found" % (thePID,theName)
RuntimeError: Process 3766 for /Kernel/Session not found
Searching /Kernel/Session in Naming Service

--- Error during Salome launch ---
Warning, no type found for resource "localhost", using default value "single_machine"

2. After running ./Salome-V8_2_0-univ_public.run i got the next error:

=======================================
Self Extracting Salome V8_2_0 Installer
=======================================

Enter the Salome install directory [default=/home/luiggi/salome] :
Salome is in English, do you want to be in French ? [y/N] : N
Installation of Salome V8_2_0 in /home/luiggi/salome/Salome-V8_2_0-univ ...
Verifying archive integrity...
Error in MD5 checksums: aff31f8bfbfd7f6c2dce3548ff70e993 is different from 9a3d458a84dd4f4cea5322ad3cc53c4e

I have followed the instructions in http://www.salome-platform.org/forum/forum_9/97231555 but i get the same error.

I hope you can help me.

BR

LUIGGI

 

 

Re: I can not install Salome 8.2.0 in Ubuntu 16.10

Posted by Christophe Trophime at June 04. 2017

apt-get install libicu57 will fix the issue about missing libicui18ln.so.57

 

If you ever run into similar error message:

* try to find the package that provides the missing library: you can apt-file search for that

* install the missing library

 

Hope this helps

Best

Re: I can not install Salome 8.2.0 in Ubuntu 16.10

Posted by craq at June 21. 2017

I'm getting a very similar error on ubuntu 16.04:

SALOME_Session_Server: error while loading shared libraries: libicui18n.so.52: cannot open shared object file: No such file or directory

When I try to install libicu52, I get the following:

Package libicu52 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libicu52:i386

E: Package 'libicu52' has no installation candidate

Re: I can not install Salome 8.2.0 in Ubuntu 16.10

Posted by DAVID Gilles at June 21. 2017

Indeed this package is from Ubuntu 14.04.

You can download the deb file from here: https://packages.ubuntu.com/trusty/libicu52, extract the required file and copy it into the debianForSalome directory of SALOME installation directory.

Powered by Ploneboard
Document Actions